On Windows 11, inside the OneDrive folder, there are three folders: 'Desktop', 'Documents', and 'Pictures'. When I put any file or folder on my Desktop screen, it automatically goes into the OneDrive folder. I've already unlinked my OneDrive folder from my PC but that doesn't seem to have done anything. When I go to 'C:\Users\{username}\Desktop', the folder is completely empty.

Ideally I would like to have OneDrive installed on my computer so I can use it, but I do not want to have my Desktop or Documents folders inside them. I would also like to put files and folders on my Desktop without having them inside the OneDrive folder.

Is there any way I can do this?


1 Answer 1


Make sure there are no current files in One Drive and then sign out of One Drive. Make sure you have One Drive set to NOT start when Windows starts.

I have One Drive installed (programs and features) and I have it set to not run and not have any notifications and it does not.

My desktop and other files are stored exclusive of One Drive; that is, not in any One Drive folder.

This works.

Note: Setting One Drive not to run with Windows start should work normally (does for me). You may need to also use Microsoft SysInternals, Autoruns.

  • 1
    @DumbMathBoy - You should also make sure OneDrive is configured NOT to synchronize the Desktop folder. Your Desktop folder likely is in your OneDrive folder, since it was configured to synchronize your Desktop, but that just a wild assumption on my part.
    – Ramhound
    Jun 24, 2022 at 18:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .