1

Today when I typed gpedit.msc in the Windows 10 search box and in the Run window (Win + R) I couldn't run the Group Policy editor.

There's this annoying error I'm getting at times when I try to run certain software: "An administrator has blocked this app for your protection." The only account on this laptop is my own. So I am the administrator.

What can I do to resolve this? According to this FreeCodeCamp post, the solution to this error is to toggle a setting in User Account Control using gpedit.

With the Group Policy, you can make changes you won't easily find anywhere else on your computer.

One of these changes can be made on the User Accounts Control (UAC) to allow apps to escape the administrator check.

To make the changes that will get rid of the error, follow the steps below:

Step 1: Press WIN + R on your keyboard to open the Run dialogue.

Step 2: In the run dialogue, type in "gpedit.msc" and hit ENTER on your keyboard.

...

P.S. I'm using Windows 10 Home. My laptop came preinstalled with it.

4
  • 1
    Is this computer Windows Home? Home does not have gpedit.
    – John
    Jun 28, 2022 at 15:04
  • You can edit 99.99% of group policies with their respective registry key. There are also solutions, to having a group policy editor, on Windows 10 Home that are not complicated to implement. You don't really specify which group policy you are attempting to edit, which by default should be "not configured", since you are running Windows 10 Home. The message you are receiving, most often is caused by a related option within Settings being disabled, instead of a group policy being explicitly configured since you are running Windows 10 home which cannot be joined to an AD domain.
    – Ramhound
    Jun 28, 2022 at 15:23
  • Not sure if relevant, but if you have Win10 Home and need group policy, you can instead use ntrights.exe. Refer to this post.
    – Arctiic
    Jun 28, 2022 at 17:04
  • 1

2 Answers 2

3

If you are running Windows 10/11 Home Edition, here is how to enable the group policy editor:

Open Command Prompt (CMD) in administrator mode and run the following commands:

FOR %F IN ("%SystemRoot%\servicing\Packages\Microsoft-Windows-GroupPolicy-ClientTools-Package~*.mum") DO (DISM /Online /NoRestart /Add-Package:"%F")
FOR %F IN ("%SystemRoot%\servicing\Packages\Microsoft-Windows-GroupPolicy-ClientExtensions-Package~*.mum") DO (DISM /Online /NoRestart /Add-Package:"%F")

After the commands are successfully executed, do Run > gpedit.msc. This will now open the group policy editor in your Windows Home edition.

2
  • Thank you. I'll try this.
    – cst1992
    Jun 30, 2022 at 9:47
  • Thank you, these commands did indeed install gpedit for me. I've upvoted your answer. However, I think I'll mark the other answer as the solution because the real issue - the error - is caused due to a PUP blocking mechanism and the gpedit is just a resolution to that (classic X-Y logical error on my part).
    – cst1992
    Jul 3, 2022 at 16:43
1

You are going about this the wrong way. You don't need GPEdit. There is nothing that it does that can't be enabled via the registry anyways.

The warning is a good thing and easy to get around.

I suggest the following and leave the actual settings alone

  1. Right click on the application giving the warning and select "Properties".
  2. Look at the "General" tab.. down at the bottom. Look for [X]Unblock. Uncheck it and select OK.
  3. If you don't see the checkbox you might be using a shortcut and need to go directly to the file. In this case, on the "Shortcut tab" choose [Open File Location] and start back at step 1.

If you want this behavior permanently disabled

  1. Open your search bar [WinKey]+s and type "SmartScreen".
  2. Find and select "reputation-based protection settings"
  3. Turn off -> Check apps and files
  4. Turn off -> Potentially unwanted app blocking
2
  • The file in question is not blocked.
    – cst1992
    Jun 30, 2022 at 9:48
  • So, Windows thinks the application is a PUP? I wonder why and how. For the moment I've reinstalled this application and it's no longer blocked, but I'll try this if the error pops up again.
    – cst1992
    Jun 30, 2022 at 9:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .