My MacBook Pro is generally a fast machine (3.06 Ghz Core 2 Duo, 8GB of RAM, 7200RPM hard drive) but VirtualBox 3.2.6 running Ubuntu 10.04 is just too slow compared to VMWare. What can I fiddle with to improve this? Within Ubuntu, I use Eclipse mostly but even booting and GNOME desktop accessories are slow...

  • Why not run Eclipse on OS X itself? – Chealion Aug 7 '10 at 0:10
  • 1
    Chealion, for a number of reasons including: different key mappings, no desire to install all required software off of MacPorts (e.g. Fuse to use sshfs and file:/// based SVN, some Java libraries with native invocations, etc.) keeping productivity/development systems separate, etc.. – Maroloccio Aug 7 '10 at 0:14
  • blog.jdpfu.com/2012/09/14/… – ecbrodie Feb 2 '13 at 1:09
  • One can also diminish the screen resolution of the Macbook(System Preference/Display/Scaled), it seems to have an effect on the rendering time and the CPU load. – user778135 Oct 6 '17 at 21:56
  • I've noticed on my Linux Mint desktops that if you create a 64bit VM and run a 32bit Linux (Mint or Debian in my case) in it that it will be terribly slow. Like take 3 hours to install just a base system in Debian (no X, no desktop, just basic system utilities). – ivanivan Oct 6 '17 at 23:41

The performance will become normal if you disable VTx and set it to use only one core of CPU. See the thread at http://forums.virtualbox.org/viewtopic.php?f=8&t=39368

  • The bug reported on that thread has been fixed: virtualbox.org/ticket/8474. But I still have problems with virtualization on VBox. – another Mar 12 '18 at 11:24
  • Is this still true in 2018? – jocull Jun 9 '18 at 1:40

This is an observation: I use the end 2016 Macbook pro (15 inch), and run Virtualbox on it. As guest system, I have Win 7 and Linux Mint. Both show poor performance, which seems to be related to the graphics.

My observation: If I use an external screen (27 inch, resolution 2560 x 1440). The VBox guests are as smooth as you would expect.

Even moving the VBox window from the Macbook screen to the external screen and back shows that on the external screen, it is fast immediately, on the built-in screen it is slow -- even for non fullscreen mode.

  • That is exactly my problem as well. The performance is fine with the external display. Have you solved the problem? – beeender Jul 9 '19 at 5:45

This is more of a work-around than an answer. I was in the same boat, the Oracle-branded version 3.2.6 was bringing my Ubuntu VM to a crawl. So I just deleted 3.2.6 and installed version 3.1.8 and everything was fine. If you're just running Ubuntu I don't think there's much of a difference between 3.1 and 3.2.


Switching from Gnome to Unity (and installing VirtualBox Guest Additions) made a huge difference for me on Ubuntu 17.10, VirtualBox 5.2.8, OS X 10.13.3 High Sierra. Source: https://askubuntu.com/a/1017107/148598

  • Did you try Gnome + Guest Additions? Any other tweaks or things to take note of? VT-x settings? – jocull Jun 9 '18 at 1:45
  • @jocull sorry, can't recall – jtpereyda Jun 9 '18 at 2:23

Just throwing this up here as it may help others significantly.

I had Ubuntu VMs (guests) that i created on a Linux host install of Virtualbox, they ran fine on the Linux machine and were very slow once I moved them to my top of the line MacBook air 2012 (2ghz, 8gb ram) . I found i could make them extremely fast by increasing the cpu count (in the vm's settings) from 1 to 2. It made approximately a factor of 10 difference (a suite of phpunit tests went from 5 minutes to about 30 seconds). I'm not sure if the slowness had anything to do with the migration from Linux to OSX 10.8.2 or if the slowness would have been there even with guests that were created on an OSX install.


This seems to still be a problem in a Macbook pro 2018, Ubuntu runs really slow, however, the only option that I had to turn on was the 3D Acceleration and that did the trick, now the VM is really fast. Hope this helps.

  • Same for me on a MacBook Pro 2018. Going to VM > Settings > Display > Enable 3D Acceleration helped. The UI is a bit blurry but that's ok for me – Jan Dec 16 '18 at 19:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.