0
Edition Windows 10 Pro
Version 21H2
OS build 19044.1766
Processor Intel(R) Celeron(R) N4020 CPU @ 1.10GHz 1.10 GHz
Installed RAM 4.00 GB (3.65 GB usable)
System type 64-bit operating system, x64-based processor

I don't exactly remember the cause of the problem, however IIRC I changed the virtual memory to custom size from automatic allocation or system managed size and it didn't restart properly and probably thereafter the problem started.

Problem & Its Symptoms:

  • Upon startup the desktop comes with a non-responding taskbar and with no desktop icons loaded. After a minute or two, desktop icons becomes visible and taskbar starts working normal.
  • Lunching windows explorer (file manager) looks working fine with all functions except manual refreshing with F5. When you try refreshing (F5), it becomes non-responsive for a minute and thereafter it starts working fine again until F5 is pressed again. The same effect is observed if refreshing is tried at Desktop icons.
  • All other apps works fine but while clicking on Browse dialog to choose the file location, sometimes it may become unresponsive for a minute.
  • The opened instance of windows explorer / file manager does all the jobs as expected but occasionally (say once in an hour) it becomes unresponsive and you have to wait for a minute.
  • "Program Manager prevents windows from shutting down" while restarting the system

Trouble Shooting:

  • /sfc/scannow completes with no issue found
  • dism's CheckHealth and ScanHealth finds no issue to resolve
  • Problem remains present with a clean boot (though I couldn't disable sophos antivirus service)
  • Problem vanishes with booting into SafeMode (Find a comparison of running services between SafeMode & CleanBoot)
  • Automatic startup repair finds nothing to repair
  • Windows Memory Diagnostic reports no problem.
  • Windows update & automatic troubleshooter for the same doesn't find any issue

Tried following proposed solution but none of them helped:

  • Cleaning File Explorer history, restoring settings to default and unchecking quick-access from "Folder Options"
  • Resetting the virtual memory (page file) to automatic/system-managed
  • Turning the fast boot on/off
  • Disabling third party extensions using shellexview
  • Uninstalling graphics driver and let the m re-installed upon startup
  • System Restore

Might have tried random other proposed solutions also, add comment for clarification.

Have not tried following:

  • Resetting windows which installs a fresh copy of Windows
  • Repairing windows using Installation Disk.
6
  • Are you on a domain network? If so, sign in as local admin or in safe-mode without networking and see if the behavior persists.
    – Arctiic
    Jul 15, 2022 at 7:55
  • Are you working in a local network, domain or remote?
    – Z0OM
    Jul 15, 2022 at 8:54
  • @Arctiic I sign in as a local admin (user who is member of Administrator Group). Tell me if any more details require, I'll share screenshot of particular settings/configuration.
    – Pandya
    Jul 16, 2022 at 2:54
  • @BlockchainOffice Local Admin Account
    – Pandya
    Jul 16, 2022 at 3:00
  • 1
    I’m voting to close this question because I, the author of the question has just upgraded to Windows 11 to get rid of the problem and hence can not verify answer any more.
    – Pandya
    Aug 1, 2022 at 16:34

1 Answer 1

1

"Problem vanishes with booting into SafeMode"

This means that some installed product is causing this problem. You will need to locate the problem by disabling products in bunches, until the problem vanishes, in order to locate the problematic product.

I would start with products that add entries to the context-menu of Explorer.

The products you can use :

2
  • One other way to see what the explorer has loaded is to use the Process Explorer and look at the DLLs loaded. I know that this isn't intuitive but you can also see the memory footprint of each DLL loaded in to get an idea of how sloppy the author was. Jul 16, 2022 at 3:25
  • I have updated the question body with comparison between CleaBoot and SafeMode. Please have a look if it is useful for troubleshooting further.
    – Pandya
    Jul 27, 2022 at 2:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .