I installed a new drive in this customer's laptop about two months ago. Brand new WD1200BEVE PATA drive. The machine worked well until about a week ago. She told me it was running extremely slow, and it is.

I've installed HDTune and checked the SMART status. Everything says the drive is healthy. 0's for read/write errors, reallocated sectors, etc. When I run the benchmark, it won't exceed 1.3 MB/s! Needless to say, at that speed doing everything on this machine is taking about 20x longer.

It is so slow that the startup Windows sound lags like it can't keep up.

What I've tried:

  • Booted into Safe Mode and ran the benchmark. Same issue.
  • Booted into Diagnostic Mode (normal boot with only absolutely necessary services). Same issue, very slow.
  • Ran ComboFix to find possible rootkits, etc. Was completely clean.
  • Ran the WD DLG Tools Quick Scan which passed. I tried running the extended surface scan but considering it is going 1 MB/s it was taking FOREVER.
  • Changed "Plug and Play OS" in the BIOS from Yes to No. There was no difference.
  • Checked the jumpers on the drive. They are correct for Single Master.
  • Booted from an Ubuntu Live CD and it runs fantastic. Like it should.

All this leads me to think the drive alone is the cause of the problems.

By the way, the machine is a Gateway model MX6426.

I'd appreciate any suggestions you may have.

Peace, Tom

  • 1
    Check if it switched from DMA to PIO. If it works on GNU/Linux, that's probably it. That would also explain High CPU utilization too and temperature. Here's a link with some info onthegosoft.com/dma_setting_nt.htm – AndrejaKo Aug 7 '10 at 15:52
  • If I read it right, he only tested the Live CD. So the hard drive probably isn't involved in that test. High CPU can occur just because of waiting for I/O operations... He could still try tools from the Hiren's Boot CD to verify it's not the OS. I guess the hard drive needs a RMA if it's under garancy. – Tamara Wijsman Aug 7 '10 at 15:56

Check device manager the hard drive may be operating in PIO mode

In Device Manager expand "IDE ATA/ATAPI controllers", then do a properties on "Primary IDE channel", go to the "Advanced Settings" tab, check the "Current Transfer Mode" it should be Ultra DMA 5.

If it is not, close that properties window, right click on the primary ide channel and select uninstall, then reboot the laptop, performance should be restored.

If it does it again you are getting multiple simultaneous read/write errors on the drive, this will cause the OS to step back the transfer mode and slow drive performance.

  • That is the issue. Wish I had posted sooner. I've been staring at this thing for a few hours. Thanks – TomWilsonFL Aug 7 '10 at 16:10
  • If it continues to revert to pio mode, I would suggest to warranty that new hard drive. – Moab Aug 8 '10 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.