I have a dual boot system (Ubuntu 22.04 + Windows 8.1 pro) running on Dell Precision M3800. Suddenly, network has stopped working, both wifi and wired, on both Windows & Linux.

Following are two events that might happened over the last 2-3 days:

  1. Windows update (the forced update it does occasionally on reboot) was interrupted in between. I knew it could be risky - but it seemed stuck hence I terminated. However, I am 99% sure network was working even after this.

  2. I might have left my system on, with power adapter turned off, overnight. So it might have hibernated OR forced shutdown due to battery discharge. However, I am not sure of this.

In any case, the biggest problem / surprise is - I reinstalled Ubuntu 22.04 just now - and still - the network adapters were not found. I am pretty surprised what could have happened at the system level that suddenly network adapter is not detected.

Any help would be highly appreciated - either to enable the adapter in windows or linux.

Thanks much Regards, Janak

  • 1
    If two different OS and even a reinstalled OS have the same problem then it is an problem on BIOS or hardware level. Check BIOS settings if the network adapters are not disabled. If they are enabled or there is not settings to enable them it is most likely a hardware defect. Get an cheap USB Ethernet adapter and try it, if it works it may be a hardware defect. Alys try the built-in Dell hardware check which may exist on your device.
    – Robert
    Jul 16, 2022 at 11:54
  • So finally - with some trial and error - I managed to find a utility "Wifi analyzer" (or something similar - don't remember the name now) on Windows, which fixed it. The default windows network troubleshooter couldn't do it. I wish I could ascertain with surity what caused and fixed it.
    – workwise
    Jul 18, 2022 at 7:38


You must log in to answer this question.