0

Fresh install as Guest VM (virtualbox) Ubuntu can't upgrade

Err:4 http://ca.archive.ubuntu.com/ubuntu jammy-updates/main amd64 libwebkit2gtk-4.0-37 amd64 2.36.4-0ubuntu0.22.04.1
  Hash Sum mismatch
  Hashes of expected file:

So far tried deleting sources file + update + upgrade

what you said worked, but as soon as I update again its the same problem Err:10 http://ports.ubuntu.com/ubuntu-ports jammy/main amd64 Packages 404 Not Found [IP: 185.125.190.36 80]

I removed sources.list and sources.list.d and it seems to be working better(update upgrade), but i still get this end of update, E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/jammy/main/binary-i386/Packages 404 Not Found [IP: 185.125.190.39 80] E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/jammy-updates/main/binary-i386/Packages 404 Not Found [IP: 185.125.190.39 80] E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/jammy-backports/universe/binary-i386/Packages 404 Not Found [IP: 185.125.190.39 80] E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/jammy-security/main/binary-i386/Packages 404 Not Found [IP: 185.125.190.39 80] E: Some index files failed to download. They have been ignored, or old ones used instead.

update
sudo apt install build-essential
E: Unable to locate package build-essential
3
  • 1
    I have Ubuntu 22.04 running as a VM in VMware. Try running Ubuntu Software Updater. Make sure Live Patch is running This works here.
    – John
    Jul 21, 2022 at 0:23
  • Also, if you can get to a terminal session, run this: ...... sudo apt-get update && sudo apt-get autoclean && sudo apt-get clean && sudo apt-get autoremove
    – John
    Jul 21, 2022 at 1:01
  • I can certainly reach the IP 185.125.190.39 and my browser shows the index of the repository. Are you sure that you have a working internet connection? Jul 21, 2022 at 21:53

1 Answer 1

-1
sudo rm -rf /var/lib/apt/lists/*

sudo apt-get update
3
  • Did this resolve your issue? Jul 21, 2022 at 21:54
  • 1
    Could you edit your answer and explain why this will help the OP? Jul 21, 2022 at 22:59
  • This does not help. Apr 6, 2023 at 17:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .