2

The Firefox browser contains a toolbar for organizing bookmarks. It places a "folder" icon next to all bookmarks folders. This icon is not needed, and it wastes horizontal space--ruining the UI.

You can find various fixes throughout the past, but I couldn't find anything current that was guaranteed to work. I tried an older solution that used to work in the past, but it isn't working now.

I'm aware that Mozilla has decided not to make this configurable, and furthermore has decided to block extensions from modifying it. But, I suspect there is some way to modify Firefox to achieve this, even if the particular solution needs to change with every version increment.

FWIW I think Mozzila is probably making the wrong design choice here. Horizontal space is just much too limited in the toolbar to waste it with things that add no value.

So, does anyone know how to hide the folder icons in the bookmarks toolbar in Mozilla Firefox 103.0 on Ubuntu Mate 22.04?

Many thanks in advance!

Edits for clarification

Here is an old solution from four years ago. This used to work. I followed it again today, for Mozilla Firefox 103.0, and it did not work.

Here is a website with a tutorial for Firefox 57 that describes the user experience I'm hoping for. In their case, they hide the folder names and replace the folder icons with something custom. That would also be acceptable.

(Hiding the folder icons and using single-character memorable unicode characters for folder names would achieve a similar effect, which is what I had been using in the past)

3
  • 1
    Can you edit your question to to a screen shot of the issue? I have Firefox on two different Linux systems and it looks fairly ordinary to me.
    – John
    Jul 21, 2022 at 12:19
  • Well, yes, the defaults are ordinary, but... I want to use something other than the defaults. Try this: create a folder in the bookmarks toolbar. Notice how it displays as a little folder icon 📁, followed by the name? Now, imagine a user who has A LOT of folders (because they like it). It's easy to imagine how the 📁 icons could cause horizontal overflow of the toolbar. At various points in the past, it's been possible to hide the 📁. I would like to do this.
    – MRule
    Jul 21, 2022 at 12:49
  • Hi @John, jbryant.eu/pages/firefoxbookmarkfavicons.htm gives a good idea of the user experience I'm aiming for. I'm operating on a small screen with limited real-estate, and need ready access to saved links for work. A compact hierarchically-organized bookmarks toolbar is a must!
    – MRule
    Jul 26, 2022 at 8:09

1 Answer 1

4

This is what I found worked:

  1. enable userChrome.css by flipping toolkit.legacyUserProfileCustomizations.stylesheets in about:config to true
  2. Locate my profile directory and create ../chrome/userChrome.css:
  • menu → help → more troubleshooting information
  • profile directory → open directory
  • mkdir chrome
  • cd chrome
  • touch userChrome.css
  1. Add these lines to userChrome
    @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 
    #personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important}
    
  2. Close and re-open Firefox (you may need to kill the actual process, not just close the window)

Edit for Firefox 69+

It appears that newer versions of Firefox have started to ignore userChrome.css by default, which caused this issue.

Following these steps will make the old userChrome.css modifications to hide the bookmark icons work: Set toolkit.legacyUserProfileCustomizations.stylesheets to True in about:config, and restart Firefox.

Edit for Firefox 72+

  • You may need to set widget.non-native-theme.enabled = false in about:config for userChrome.css to take effect.
  • You may need to remove the @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); line from userChrome.css
1
  • Worked for me too. Thanks! Mar 29 at 8:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .