0

I have a Raspberry Pi 3+ and I boot Raspbian on an SD card sold with the Raspberry Pi 3+, I specify that the SD card was therefore already flash when purchased.

For a few weeks I had planned to make myself a NAS server with my own Python server and React application and stored all the data from my NAS on an external hard drive connected by USB to the Raspberry Pi 3+.

The problem is that if the hard disk is plugged in, the Raspberry Pi 3+ always wants to boot from the hard disk and not the SD card, which creates a big problem because there is no flash on the hard drive and it throws a console error on boot to say it can't find a boot.

Here is the error obtained when switching on with the external hard drive connected:

error 110 whilst initializing sd card

Priorities are supposed to be SD Card > USB, so I don't understand why it insists so much on connecting to the HDD and not the SD Card, also when I remove the HD from the RPi it boots normally to the SD Card and there is no problem.

I looked everywhere for a solution to this to change the boot order of the RPi but I can only find answers to do the opposite: boot an RPi from a USB flash drive, I also tried to mount the HD but the 'OS returns me that it is already mounted.

So I would like to understand what I have to change, if there is a solution that works with this OS? because I don't want an OS for NAS servers, I really want to do it myself and keep my current environment.

4
  • @Greenonline Thank you for your answer ! I already tried this option, in raspi-config the boot options are limited to console or GUI display... I also looked at the advanced options and couldn't find anything to set priorities or find them I also can't update the tool to manage the configuration because I get an error trying that. what happens is that once the hard drive is connected, when booting I get this error: error 110 whilst initializing sd card
    – Naikho
    Jul 25 at 16:14
  • Have you tried echo program_usb_boot_mode=0 | sudo tee -a /boot/config.txt followed by a reboot? This should get written to the internal firmware on the reboot. Also, as you can assume, =1 turns it on. Also, I am not blindly giving you info from a website. I use it. Jul 25 at 16:20
  • 1
    This is a decent question, but I edited it because the title wasn’t clear and the error should have been placed in context in existing text. Also bolding every few words at the beginning is really unnecessary; the details are very clear. No need to bold those items. Jul 25 at 16:21
  • Please edit your question to state exactly what you have tried, in order to save people from suggesting solutions that you have already tried. Jul 25 at 16:21

1 Answer 1

1

My microSD card was simply dead. I changed it after multiple tests which showed that it was an error of the card and not of the hard disk.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jul 25 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.