0

I want to use my Windows VM with multiple monitors (with Windows as host OS). I am using the VMware Workstation 16 Player.

While in full screen mode there is the option to Choose a monitor layout (see screenshot). That would be exactly what I want, but clicking any layout has no effect. Unity mode is working well, but not always what I need.

Screenshot of the 'Choose a monitor layour' dropdown menu

I played around with the Display settings in the virtual machine settings e.g. specifying the monitor settings directly. I have not tried to use a different guest OS, I want it to work for windows. There was also not setting inside the guest OS to enable more monitors or something similar.

1 Answer 1

1

Workaround:

Go to File -> Preferences

Screenshot of the Player dropdown menu to navigate to preferences

and select Light as your color theme.

Screenshot of selected Light color theme

You should now be able to use the Choose a monitor layout menu as expected.

I tested this workaround on different machines and it worked both times. Also switching back to Dark or System (in case your Host is using dark mode) for the color theme keeps your monitor layout settings, but you're stuck with that setting then.


I found this workaround thanks to this (hard to find) answer by JGrover on the vmware community website.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.