Windows installer will create 3 volumes from unallocated space but errors on installation. iirc the partitions are EFI, wsr(?) - each a few 100mb only max, and the main data volume which takes up the rest of the space.

When I try to install Windows onto the largest volume on the drive I get an error We couldn't create a new partition or locate an existing one.

I tried following this guide https://appuals.com/fix-we-couldnt-create-a-new-partition-or-locate-an-existing-one/ . The last time I tried I got an error about the drive having a MBR partition table.

I've used the same USB drive to install Windows 11 previously on the same machine so I'm a bit stumped as to what the problem is.

The drive had a working Windows 11 install on it until I wiped it under linux. I've recreated the partition table and zero'd out the disk but so far the issue hasn't changed.

I see there's a similar issue Windows installation: Couldn't create a new partition or locate an existing one but it doesn't resolve my problem.

Motherboard is a Gigabyte Z490 Vision-D

Setup Logs: setuperr.log setupact.log 1/2 setupact.log 2/2

Step 1 - Install to Unallocated Space Install process: beginning with unallocated space

Step 2 - During installation error occurs Error encountered trying install to unallocated space

Step 3 - Installing on the newly created volume gives an error Installer creates partitions but errors when trying to install to them

Partitions created by Windows 11 Installer This is the partition map created by the windows 11 installer when beginning from unallocated space

enter image description here The partition table has been recreated as GPT but the issue remains

enter image description here This is the output of diskutil list disk

  • 1
    Drive 1 shouldn’t have any partitions while trying to install it
    – Ramhound
    Commented Aug 2, 2022 at 12:15
  • @Ramhound The initial install attempt is onto Unallocated Space - images 1 and 2. The Windows installer creates the partitions on Drive 1. Following this the machine is rebooted and installation is run on Drive 1 Partition 3.
    – Scottmeup
    Commented Aug 2, 2022 at 12:18
  • @Ramhound MBR is the problem, not unallocated space vs. partitions. Commented Aug 2, 2022 at 14:50
  • 1
    I do not understand how anyone could’ve arrived at the conclusion you’re looking at a MBR table. Please take another look. Primary does not imply MBR. MBR2GPT is not required, because a system is not installed. // In the meantime, OP, I suggest you do what the error says and look at the setup log file. While the setup is running, you can find them in X:\Windows\Panther. You can access a Command Prompt using Shift+F10.
    – Daniel B
    Commented Aug 2, 2022 at 21:40
  • 1
    Hm unfortunately it’s not entirely clear what the state was when Setup started. It appears the partitions already existed? That’s not ideal. I recommend doing the following: Remove/disconnect all other drives but the one you want to install on. Delete all partitions from this drive so you only have a single “Unallocated” entry. Then install there. If that does not work, provide the logs from that attempt.
    – Daniel B
    Commented Aug 3, 2022 at 7:24

4 Answers 4


From the Setup log files it appears that Windows is searching all around for the EFI System Partition (ESP) but somehow doesn’t find it even though it’s there. Maybe some other drive is confusing Setup.

Earlier, Windows Setup was notorious for placing the boot partition (the ESP predecessor, if you will) on whatever drive, which often enough was not the drive the Windows system partition was installed on. This lead to confusion and boot errors when removing or replacing seemingly unrelated drives. It appears this behavior still exists.

My suggestion to ensure the installation is “self-contained” is to remove/disconnect all other drives, so only the target drive and the installation USB/DVD drive remains.

The target drive would ideally not contain any partitions or at least no existing EFI System Partition.

If no (zero) partitions are present, Windows will also automatically create a GUID Partition Table (GPT, UEFI Boot) or MBR Partition Table (Legacy Boot) as needed, no fiddling with diskpart, convert gpt or convert mbr required.

Once the installation is finished, you can put back the other drives and assign drive letters as usual.


During the installation, delete the partitions whose space you wish to use for the installation. Once that space is converted into Unallocated, install Windows into this space.

If you have deleted multiple non-contiguous partitions, use a third-party bootable partition editor to move the partitions on the disk so that the Unallocated space becomes one unique space.

  • I've tried this a few times, and deleted all partitions on the drive and let Windows installer re-create them. It still errors on We couldn't create a new partition or locate an existing one when the main volume on the drive is selected.
    – Scottmeup
    Commented Aug 2, 2022 at 10:52
  • Are you selecting Unallocated space, or an existing partition?
    – harrymc
    Commented Aug 2, 2022 at 10:53
  • I started with unallocated space and selected that. Windows 11 installer created 3 partitions and errored. After that I selected the largest partition that Windows isntaller had created and it errorred again.
    – Scottmeup
    Commented Aug 2, 2022 at 10:55
  • I can think of these reasons for error: (1) The unallocated space was not large enough, (2) The installation lacks a driver for the disk (very unlikely), (3) The disk has a hardware problem. For the third point, try to format the disk with slow format (not quick) for all sectors to refreshed. This will take some time for a large disk.
    – harrymc
    Commented Aug 2, 2022 at 11:00
  • I'll give it a shot. The system was working until I wiped it. It's a 1TB SSD and the install worked a couple of weeks ago. I'm wondering if letting a linux partition manager touch it has left any traces that windows doesn't like.
    – Scottmeup
    Commented Aug 2, 2022 at 11:05

What just solved this for me was to delete some leftover "System" partitions (from former Windows/Linux installs) on OTHER drives. Once there was only one System partition left, the one created by the installer itself, the installation started just fine, no further errors.


I had this error with the USB I prepared using instructions in How to Make a Windows 10 USB Using Your Mac - Build a Bootable ISO From Your Mac's Terminal. I created a USB recovery drive from another Windows machine and it worked fine.

  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Mar 15 at 20:10
  • Thank you - for me, this was it! I tried everything and even bought a new hard drive - never questioned the boot USB, because the installation got so far. Commented Jun 15 at 12:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .