I have a Logitech MK295 keyboard and mouse. Actually I have tried 2 brand new ones out of the box. Whenever Windows 11 goes to a lock screen and is eventually released by pin or password, the scroll button on the mouse stops working. The only fix is to reboot.

I have tried adding another wired mouse and it doesn't work either, the scroll wheel that is. That points to the OS being the underlying cause. I can't seem to find anything online mentioning a similar issue anywhere.

The drivers are built in. I checked Logitech's site, and there are no drivers to download. It's really annoying and I am pretty much ready to just wipe the whole machine and start all over.

It's Surface Pro 15" about 2 years old connected to a Surface Dock and two monitors. I have tried the USB adapter in the dock and directly on the Surface, same results. I have updated the OS with all recent updates and I have checked all the mouse and scroll settings.

Any ideas or am I spending the next few days rebuilding?

  • I have a LogiTech K540 keyboard/mouse combination on a Windows 11 Pro desktop machine. The mouse wheel does not lock up. Are you able to try a different model of mouse on your Surface Pro machine to see if that helps?
    – John
    Aug 2, 2022 at 20:30
  • I did, same result. Aug 2, 2022 at 20:36
  • There must be some compatibility issue with the Surface Pro. Otherwise, I am not sure.
    – John
    Aug 2, 2022 at 20:38
  • I should add that I run this on another Surface through a Surface Dock as well, Windows 11 and it never shows this behavior. That's why I feel like something is FUBAR on this particular machine. Aug 2, 2022 at 20:42
  • 1
    That is almost impossible to debug.
    – John
    Aug 2, 2022 at 20:44

1 Answer 1


As I suspected, and after some responses, I decided to image my computer using Macrium's imaging tool, so I had a backup, and then I ran a Windows 11 system reset. I chose to keep my data, and it took about 20 minutes to complete. Once I was able to log back in and create a profile, I tested the scroll wheel, and it worked. I tested Windows lock a few times throughout the day, and the scrolling worked afterward. I do wonder if I should have tried a new profile instead of resetting, but that ship has sailed. I hope this can help someone else in the future. Thanks for the responses.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .