I'm in the process of installing the newest version of my BIOS driver and I have to use FreeDOS because I don't have windows (I'm using Ubuntu 9.10). So I'm following AndrejaKo's advice here. The problem is that when FreeDOS comes up and I choose option #5: FreeDOS Live CD only, I don't end up with the same screen as AndrejaKo's. Rather, I get this:

UMB's unavailable!
XCDROM V2.3, 7-24-2006.
Driver name is "FDCD0000".
No CD-ROM drive to use; XCDROM not loaded!
FreeCom version 0.84-pre2 XMS_Swap [Aug282006 00:29:00]
Cannot open CD driver FDCD0000. SHCDX33A cannot load!
There is no CDROM, or the wrong CD-ROM!


Does anyone know what this means? It seems to indicate that there is a problem with my CD driver, but I do get that far in FreeDOS from a live CD.. AND other CD work fine on my machine... So what's the deal?

edit: In System->Administration->Disk Utility, Under CD/DVD Drive, I get this:

Optiarc DVD RW AD-75805 No Media Detected

If I start hardinfo and go in Computer>Summary, I find a section called SCSI Disks with this entry:

Optiarc DVD RW AD-7580S

I don't know if this can be useful.

By the way, my computer is an Acer Aspire 5536-5519

  • How is the CD drive connected to the PC - which interface? Aug 8 '10 at 21:18
  • @Moritz Both: I don't know how to get that information... There must be a simple command which could find that for me?
    – Shawn
    Aug 9 '10 at 18:56
  • @Moritz Both: I edited my thread with some information, I don't know if this is what you're looking for..
    – Shawn
    Aug 9 '10 at 22:39

Sounds like you are using a sata-connected DVD drive (Macbook?).

I think the XCDROM driver is for IDE devices only. There are other drivers in FreeDOS that work with SATA DVDs (GCDROM) so perhaps a different menu option or setting from the live CD menu will load them.

If there is no such option you can add gcdrom to the config yourself, follow the instructions here.

  • Hi! Do you know any option which will not load himem or emm386?
    – AndrejaKo
    Aug 10 '10 at 8:38
  • @AndrejaKo Why? Are these undesirable for some reason? Should I give those options a try anyways? @Console By the way, I don't have a Macbook, I have an Acer Aspire 5536-5519
    – Shawn
    Aug 10 '10 at 16:57
  • @Shawn Well phlash16 refused to work when I booted DOS with himem and emm386 and said that I need to run it without them, so yes they are undesirable.
    – AndrejaKo
    Aug 10 '10 at 17:30
  • @Shawn Actually, do try those options. Nothing bad will happen if you do and if they do work, there may be a way to unload emm386 and himem after boot.
    – AndrejaKo
    Aug 10 '10 at 17:39
  • @AndrejaKo @Console I tried both Himem and emm386 and himem only options. They both produce the same error, with additionnal stuff concerning himem.. Basically, they don't help. I also tried running FreeDOS from a live USB key, but when I choose Default, it just says bad kernel image or something like that, so I never even got to the freeDOS menu that way.
    – Shawn
    Aug 10 '10 at 19:47

As an alternative, try checking your BIOS to see if there is an option to switch to ATA compatibility mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.