0

I have the APC 1500 Smart UPS with SmartConnect and the PowerChute Business Edition server edition 9.2 Build 604. I had configured the email to use Gmail to send me notifications when there were any power outage issues to my personal email, which had been working fine up until May 2022 when Gmail turned off the less secure app feature, which was needed for PowerChute to send the notifications. Now, due to more secure login requirements, Power Chute cannot login as a third party app into Gmail and send the notification. I use my UPC for my home office and it is just connected using the Smart Connect to my workstation.

I tried using NetCore and SendGrid, but the SMTP configuration fails when I tried to run a self test which is configured to send me an email notification. I am unable to send from PowerChute. Are there any other options to use PowerChute to configure email notifications? Perhaps I've not configured something correctly, but the configuration is really simple:

smtp.netcorecloud.net port 25 TLS Username and Password using basic authentication

I don't have a lot of knowledge with how smtp servers work or how to debug the issue with email. Any suggestions or how to troubleshoot is appreciated.

2
  • 1
    Get a free email account at any number of sites, such as mail.com, and send the outgoing mail through that account. See lifewire.com/best-free-email-accounts-1356641 for more suggestions. Aug 4, 2022 at 18:41
  • I tried with NetCore and SendGrid both and it didn't work. Gmail is what I was using and no longer works because of some new security that was implemented. Is using Yahoo or Mail.com any different than using NetCore and SendGrid? What's the difference? Aug 4, 2022 at 19:16

3 Answers 3

1

I'm unable to vote or comment. So I'll post it as a separate answer.

Seems PowerChute business edition has a bug, if you configure it to use SMTP with TLS no emails are being sent out, I confirmed this using Wireshark (I observed no SMTP traffic being generated at all). The solution is to turn off TLS in the SMTP settings. Please note, some services won't accept non TLS SMTP.

0

I turned off TLS and it worked. Which is a surprise as TLS works from my Synology and my APC AP9630s.

PowerChute Business Edition Agent Version 10.0.5.301

1
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 30, 2022 at 16:56
0

It's more secure to use TLS. And it should work with Gmail. First ensure you have 2-step verification enabled on your Google account (https://support.google.com/accounts/answer/10956730?hl=en). If not, then you probably should do so for security. This also allows you to configure an app password (https://support.google.com/accounts/answer/185833?hl=en) you can use with PowerChute Business Edition. After you configured the app password on your Google account, open E-Mail Settings page in the PowerChute web UI and configure the following:

  • SMTP Server: smtp.gmail.com
  • From E-Mail Address: [email protected]
  • Port: 587
  • Use SSL/TLS: TLS
  • Enable Server Identity Check: Enabled
  • To E-Mail Address: email address for receiving notifications
  • Enable Authentication: Enabled
  • Server Username: [email protected]
  • Server Password: the app password you created (not your gmail account password)

Apply the changes. And then click the Test button to verify you successfully receive a test email.

Hope this helps you or anyone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .