7

What is wrong with my SD card and is it salvageable? At very least to get the current data off.


Information: I have an 8 GB Transcend Class 6 SDHC card that I got for my camera recently. It was working fine until one day out hiking the camera just reported that it could not save and there were no pictures on the card. I plugged it into my computer (running Ubuntu 10.04) and it said:

Error mounting: Mount: /dev/sdb1: Can't read superblock

It is partitioned with a master boot record and a FAT file system. nothing out of the ordinary that I can tell. What might be wrong and is it at all possible for me to recover those pictures?

And no, I did not drop anything.

3

Looks like Ubuntu is getting confused and trying to mount it as an ext3/4 filesystem (which have superblocks). You might want to try mounting it explicitly as vfat.

mount -t vfat /dev/sdb1 /your_mount_point_for_SD_cards

HOWEVER, I'm guessing something has actually corrupted the thing. If it shows up in your device table at all (ls /dev/sdb*) then you might be able to see if it's still readable with the dd command. something like "dd if=/dev/sdb1 bs=1024k count=10 | less" should give you an idea if it's readable. Even if readable, the ability to reconstruct previous files is questionable.

You could also try mounting it on another computer but that's a long shot.

  • Try sudo fdisk -l instead of ls /dev/sdb*. – Hello71 Aug 8 '10 at 23:06
  • Well, I've also tried it in windows XP. that just broke it to tears and begged me never to do it again I'm convinced. XP was stumbling all over it's self trying to mount and access the card. the dd command you gave failed. I'm thinking the card is toast... :( – Narcolapser Aug 8 '10 at 23:52
2

I too had this issue with my mobile's SD card and I was unable to browse it from both Ubuntu and Windows. The partition was FAT32 so I was hopeful to get it fixed via Windows.

I ran following command in CMD to get it working again:

CHKDSK f: /F /V /R /X

Note: f: was the path of my SD card.

Excerpt from Microsoft's website about the CHKDSK command:

The complete syntax for Check Disk is as follows:

CHKDSK [volume[[path]filename]] [/F] [/V] [/R] [/X] [/I] [/C] [/L[:size]]

The options and switches for Check Disk are used as follows: volume Sets the volume to work with path/filename Specifies files to check for fragmentation (FAT16 and FAT32 only)

/F Fixes errors on the disk

/V Displays the full path and name of every file on the disk (FAT16 and FAT32); displays cleanup messages if any (NTFS)

/R Locates bad sectors and recovers readable information (implies /F)

/X Forces the volume to dismount first if necessary (implies /F)

/I Performs a minimum check of index entries (NTFS only)

/C Skips checking of cycles within the folder structure (NTFS only)

/L:size Sets the log file size (NTFS only)

/B Re-evaluates bad clusters on the volume (NTFS only; implies /R)

0

This may not be much use if you are trying to recover data but I had the same issue with a blank SD card on Fedora and after plugging it back into a camera and running a format from there, it began working again on Linux.

0

There's a Windows application called BadCopy Pro that's usually a last stop for data recovery on flash cards.

0

I know this post is pretty old, but maybe someone like me in 2016 or later will still be looking to solve such problem - since answers here didn't worked for me too.

Had the same problem with my SD card. Before it happened I copied photos to my usb-drive and some of them had problems opening. I googled and read a few forums here and there and started to suspect that my laptop card reader was faulty. Since it couldn't be mounted I used my other SD-card-reader and GNU ddrescue to make image of SD card - in case something would go wrong. It worked flawless and to my surprise found no "bad blocks". Now I was sure my laptop card reader caused it all.

So I was ready to search a manual fix for this. First I found "Design rule for Camera File system" and "Design of the FAT file system" in Wikipedia and one of its sources "Understanding FAT32 Filesystems". From them I concluded that I have no superblock and my FAT32 is corrupted. Wanted to assess the damage and try to repair it in hex editor, but it meant a lot of time to go dipper in FAT32 so I set this thoughts aside, because found quick solution from "Free software for data recovery testing". I choose PhotoRec/TestDisk and it worked just fine, recovering about 95%-98% of photos (it actually worked even after I formatted my card). Then I formated SD-card and copied there all recovered photos. It worked fine. On a second card reader of course. Maybe later i will get back to those few photos left unrecovered but for now I'm done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.