My mouse is currently having trouble with Click and Drag. It moves well, it clicks well (including double click); but it will not click and drag correctly. When dragging it just drops the highlighted area almost immediately after starting it.

The operating system is Windows 7 x6, and the mouse is a Microsoft 5 Button laser wired model that's approximately 3 years old.

The problem is relatively new, but has been happening consistently for several weeks through several reboots. Is there anything to try besides buying a new mouse?

  • A new mouse fixed the problem. – C. Ross Aug 12 '10 at 21:38

The buttons on a typical mouse are small mechanical switches, and like all mechanical devices, they do go bad. Even if the switch contacts are just dirty, it's unlikely that you would be able to clean them, because they are usually sealed units. I think you will have to replace the mouse. To find out for sure, try another mouse as a test.


I once ran into this where I was trying to drag some emails to a folder an it wouldn't do it.

Of course restarting the machine fixed it but what I ultimately did was press Esc and I was able to drag again. Don't ask me why but it worked for me. Could be that Windows is stuck on trying to do something and you just press Esc and it goes back to normal.

Hope this helps.

  • I occasionally have Windows thinking I'm pressing the CTRL or ALT key. Doesn't fix until I figure out what the heck is going on and tap that key. Rebooting works too. However, if it's been happening for several weeks and several reboots, I doubt that's the problem. – TuxRug Aug 9 '10 at 18:35

I have been dealing with this for a long time. Pressing the Esc key worked for me.

No idea why, but it beats rebooting.


On my version of Windows (Vista 64) I can click and drag on the desktop, drawing a selection rectangle as I go. This works using both the left and the right mouse buttons. Anyway, this would allow you to test the mechanical problem idea mentioned by boot13. It's a fair bet that one button has an intermittent failure, but much less likely that both left and right buttons have a very similar failure. If neither allow you to drag properly, the problem is elsewhere.


This is not always a mouse problem... I have this problem on MANY of my Windows 7 machines. It is an intermittent problem and is most definitely some issue with Windows as I can change to a new mouse 5 times and the same behavior; only restarting the entire machine temporarily fixes it.


I just had that issue tonight with my brother's computer: I could do everything with the mouse but click and drag so I ended up removing the last program installed (Rocketdock) and everything worked as normal. So if any of you are using Rocketdock and are having that problem in Windows 7 Home Premium 64bit, try removing it.


I've been experiencing this problem off and on for a year now, since March 2014. Most online forums provide as work arounds instead of addressing the actual issue. Although there was one post that led me to pay attention to the save function.

Through observation, I have been able to determine that the source of the problem lies with Windows 7 and Microsoft Office's implementation of Autosave. More directly, anytime a Microsoft Office product is performing a save function, the ability to left click and drag is lost.

Yesterday, I disabled the Save AutoRecover feature in Microsoft Word and regained the ability to click and drag. I shutdown my computer last night.

This morning less than 2 hours after booting up, I lost the ability to click and drag while working in Word. Funny....I did however have Microsoft Excel running with two worksheets; and, Save AutoRecover was enabled.

So, I closed Excel and immediately regained click and drag function within Microsoft Word.

If someone else can please test my hypothesis and confirm, this would be greatly appreciated.


At my case, I have removed the top cover of my Microsoft mouse using my nails. Cleaned all dust with a cotton swab especially at edges and every thing back to normal

I suspected the battery at the first place and changed various batteries with no result.

Not the answer you're looking for? Browse other questions tagged or ask your own question.