13

I don't see the "hibernation after X minutes" option in my Windows 11.

enter image description here

On other computers I had, there was an option in Control Pane > Power Options > Change plan settings > Change advanced power settings. There i could set the time after which the computer should go into hibernation.

Note that:

  • I have hibernation enabled and can see it in the Start Menu > Power
  • The registry keys HibernateEnabled and HibernateEnabledDefault are set to 1

My environment:

  • Windows 11 (21H2 Build 22000.856) (comes from DELL website)
  • Laptop DELL Vostro 15 5510

How to achieve this in Windows 11?

3
  • Check Control Panel, Power, Choose what closing the Lid does and ensure Hibernation is selected there. Then update both BIOS and Power Management drivers. Try that.
    – anon
    Commented Aug 22, 2022 at 7:10
  • Try in an elevated CMD to enable hibernation with powercfg /h /type full.
    – harrymc
    Commented Aug 22, 2022 at 8:29
  • The documentation on powercfg says that type full changes the type of hiberfile, nothing about turning on "hibernate after": learn.microsoft.com/en-us/windows-hardware/design/…
    – NewSites
    Commented Feb 7, 2023 at 3:11

1 Answer 1

17

This command-line/registry edit should bring "Hibernate after.." option in the advanced power options dialog:

From Admin Command Prompt, run:

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\9d7815a6-7ee4-497e-8888-515a05f02364" /v "Attributes" /t REG_DWORD /d 2 /f
8
  • 2
    Is there documentation of this setting? I want to get "Hibernate after" back, but I'm not going to mess around in the registry without knowing what I'm doing. Also, before making this change, I'd like to know why MS removed it, so I can decide if it's a change that it's okay to override.
    – NewSites
    Commented Feb 7, 2023 at 2:15
  • Brilliant! Thank you - a days work down the drain wrestling with this. (And if you're [rightfully] nervous about using the reg add command, just go into regedit and find that key and change value of Attributes from 0 to 2).
    – TomB
    Commented Jun 24, 2023 at 21:22
  • 1
    This shows the settings, but the system doesn't respect it. Still doesn't hibernate after the time set. (Alienware m15 r5)
    – Kaigo
    Commented Sep 1, 2023 at 17:18
  • 1
    To see the "Hibernate After" option we should close the Power Plans window and reopen it. In my case, closing the "advanced power settings" wasn't enough, but the good news is that we don't need to restart our computers :) Commented Dec 22, 2023 at 21:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .