1

I recently had to backup and restore my Windows OS and data from a system image. Everything seems to be working fine, except for WSL. Whenever I try to start up my WSL Ubuntu distribution, I get the following error:

The operation timed out because a response was not received from the virtual machine or container.

[process exited with code 4294967295 (0xffffffff)]

I tried installing the Kali Linux distribution, but that also hung at startup, albeit, without any error message. Additionally, I was thinking of exporting my WSL Ubuntu distribution, uninstalling it, disabling/re-enabling WSL, and then re-importing, but I'm not even able to run wsl --export Ubuntu ubuntu.tar.

Any ideas on what the issue might be and how to fix it?

Additional Info
$ wsl -l -v
  NAME      STATE           VERSION
* Ubuntu    Stopped         2
$ wsl --status
Default Distribution: Ubuntu
Default Version: 2

Windows Subsystem for Linux was last updated on 4/18/2022
WSL automatic updates are on.

Kernel version: 5.10.102.1
2
  • Sounds like the file was deleted have you tried to reinstall it?
    – Ramhound
    Aug 27, 2022 at 23:28
  • I did try re-installing WSL and replacing the ext4.vhdx file with that of my original (malfunctioning) instance of Ubuntu, but it did not work. However, a new install of Ubuntu worked fine for some reason, so I ended up deciding to recover my data from the vhdx file instead, and am in the process of setting up my dev environment again. In case it helps anyone, here are the instructions I followed to recover my data from the vhdx file.
    – jinscoe123
    Aug 28, 2022 at 17:45

0

You must log in to answer this question.

Browse other questions tagged .