0

So,

I can connect to any site on the internet, except my own website, which I host on my private network

I can connect to my own website from anywhere else on the internet, except my own network.

I know this because I can switch my phone off of the wifi and use LTE to access my website.

  • my upcoming test is to take a laptop to a coffee shop and inspect the browser network tab when I visit my site, to see what happens when it's successfully resolved.

There are no special browser settings that I can see that are set to block this domain

  • NOTE: "that I can see", I may know a lot of places to look, but I doubt I know them all.

I have purchased DNS Server services along with my domain name and they point to the correct IP address.

My private network's DNS server has proper A entries that point to the external IP address. I know this because I can ping my webserver via the FQDN and ping on cmd resolves the external address, as it should. When I type my FQDN into a browser, the network tab shows "unknown" in the "remote IP" column

MY PC on my local network uses the local private DNS, and Google's backup DNS (8.8.4.4) and no matter what I set the DNS servers to (My ISP's, Google's only, my routers) my website's domain name resolves correctly via ping to my external IP address. But not within a browser.

  • I have tried switching this to local DNS and (Router or Gateway) but neither seem to fix the issue

This has been going on at least a year and I just haven't had time or reason to look into it.

I can't seem to find what I'm missing. Although I have noticed that in Win11 when I enter my DNS server's address, the dropdown shows "Unencrypted only", so perhaps I need to upgrade my DNS Service to allow browsers that use DOH or DOT to even SEE my website when resolving it's IP?

Last point is to say that this USED to work. When I setup the servers I was able to use a browser to navigate to the URL and check that the site was properly deployed.

does anyone know? I don't know enough about this lower-layer, my strengths are in the presentation and data collection layers.

1
  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer.
    – Community Bot
    Sep 11 at 20:08

1 Answer 1

0

After talking with a knowledgeable fellow on another forum, this is due to NAT Hairpinning not being enabled on my router. Since my ISP owns the router and reports that NAT Hairpinning is not supported on said router, my only solution is to acquire another router that does support NAT Hairpinning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.