1

I have a CI329 Zotac PC with Win 10 Pro, that is to be used for occasional RDP access.

It is configured to automatically go to sleep (simple standby, no hibernation) after a certain inactivity period. When it is asleep a tentative RDP access does not wake it.

Wake-on-Lan is enabled in the BIOS, and in the settings of the Wifi card in the device manager I have checked the option "Allow this device to wake up the PC from sleep". But still the PC is not awaken by the RDP access.

I then unchecked "Allow wake-up only by magic packet", which was checked by default. Now it's ok, the RDP connection wakes up the PC. The problem is that the PC does not longer go to sleep by itself. And when I put it to sleep manually, it is always awaking on its own (I mean without doing anything for that).

It's a mini fanless PC that does not use much power when idle, but I would like a more satisfactory solution: how to wake a it when accessing it with RDP, without disabling the automatic "go to sleep" bahavior?

The RDP access (and thus the wake-up) must be possible from the internet (for RDP I have already opened port 3389 on the box).

4
  • Just allow the monitor to go black and leave the PC idling. That is what I do. Modern decent PC with SSD drives should idle at between 10 and 15 watts.
    – John
    Sep 12 at 13:01
  • I use a separate WakeOnLan program, port forwarding only for the magic packet, and the vpn for RDP access. Opening the firewall for direct RDP access is not best practice.
    – user165568
    Sep 12 at 13:04
  • @John this PC is connected to a TV which is off most of time. It is used only for playing videos or for remote access. I am sure it is less than 10W when idle, but it is still 10W too much if they can be spared :)
    – PierU
    Sep 12 at 13:10
  • @user165568 I accept the risk for the internet access (there's a strong password). Any recommendation for a WoL program (for macOS actually) ?
    – PierU
    Sep 12 at 13:19

2 Answers 2

2

If your RDP connections can wake the computer, so can anyone else's. Allowing inbound RDP at port 3389 from the entire Internet means you'll be receiving unwanted RDP connections every minute – testing your system for common passwords and/or unpatched exploits that used to be plentiful in the Windows RDP server code.


Another, partially related problem:

Disabling the "Only allow management stations..." option activates "Wake on pattern" functionality, in which the OS configures the network card to recognize specific packet headers such as ARP queries or TCP SYN handshake packets. This does not inherently prevent the computer from going to sleep – but the problem is that it'll wake the computer on any connection attempts, not limited to just RDP.

Unfortunately, Windows doesn't offer any configuration on what patterns it'll enable – it's all or nothing. So your system will be woken up if another computer in the LAN tries to reach it via SMB or SSH or HTTP. (For example, my Android file manager automatically tries to connect to configured network servers so that it could show the green/red "online" indicator...)

Meanwhile, Linux does allow the wake patterns to be customized, but when an ARP query is made, the system still doesn't even know yet what kind of connection it'll be receiving nor from whom – this might be improved by Ethernet NICs supporting "ARP offload", but I don't know if that's a thing on your hardware.

2
  • If I understand correctly there's no solution here, and I have to accept that the PC is always on?
    – PierU
    Sep 12 at 13:04
  • You can definitely try to make it less bad by changing the RDP from default to something else, but it can still be triggered by a full port scan, so its not an ideal solution. But worth trying nevertheless. It is recommended to change it to a port between 30000 and 65535 and preferably not a port that looks too much like 3389, such as 33389 as that is frequently checked too.
    – LPChip
    Sep 12 at 13:14
0

In the settings of the Wifi card in the device manager I have finally re-checked "Allow wake-up only by magic packet", as it was initially. So the PC normally goes to sleep and is longer waken up permanently.

I have installed on Wake-on-Lan app on my phone, and on the router I have redirected a port xxxxx to the port 9 on the PC. So now, from the internet I can wake up the PC using the public IP address of the router, the port xxxxx, and the MAC address of the PC. Actually I am even using my personal domain name that point to the public address, it works. In the WoL app, I had also to set the subnet mask to 255.255.255.255, as it was not working with the default 255.255.255.0 (which is adapted when configuring the WoL app to operate from the LAN itself, not from the internet).

EDIT: Well, actually it doesn't work that well... It seems that when the PC has been sleeping for a too long time (say 48h) it cannot be waken from the internet (but this is still possible from the LAN). I will open a new question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.