4

I have been using Ubuntu 22.04 for couple of days , the wifi was working fine, one fin day i noticed wifi adaptor not found working upon booting tried various steps including re installing driver with no success

output of wireless info tool is https://pastebin.ubuntu.com/p/tc77Rg4dgf/

the following output from nmlci shows "plugin missing"

wlp13s0: unmanaged
"Realtek RTL8723BE"
wifi (rtl8723be), 44:1C:A8:03:A3:2F, plugin missing, hw, mtu 1500

i have tried every possible solution in the forums , but if no avail from last few days Any advise is appreciated, thanks

4
  • 1
    You may want to have a look at this: unix.stackexchange.com/questions/408012/…
    – Robidu
    Commented Sep 16, 2022 at 19:17
  • @Robidu i have seen this solution but no avail as there is no NetworkManager-wifi package in ubuntu Commented Sep 17, 2022 at 6:17
  • 1
    Same problem here. Ubuntu sucks every year more and more. Simple solution ? Quit using ubuntu. Go for another distro.
    – Peter
    Commented Mar 14, 2023 at 14:13
  • @Peter Which one has less problem or more stable? I am open for it. Thanks
    – Harry
    Commented Jun 15, 2023 at 15:45

4 Answers 4

2

Ubuntu does not always have needed WiFi adapter drivers, particularly, in my experience, for Realtek devices. Perhaps the original driver worked for a short while, although that it should work, and then stop, does seem odd.

However, you can download drivers and install them, with instructions at AskUbuntu, or update Ubuntu 22.04 to a newer kernel, which might include a better driver:

  • In Terminal, enter uname -mrs to determine the current kernel version.
  • Check and get any needed updates by entering sudo apt update && sudo apt upgrade.
  • Add the ppa for the kernels: sudo add-apt-repository ppa:cappelikan/ppa -y
  • Again, get the update list, now that the new repository has been added: sudo apt update
  • Install the latest mainline kernel: sudo apt install mainline -y
  • Reboot.

Hopefully, the latest kernel will handle the Realtek RTL8723BE better.

4
  • Thanks, still not working here is the output of lshw - c Network <pastebin.ubuntu.com/p/qBPTHG6RCb> Commented Sep 17, 2022 at 6:14
  • uname -mrs return ` Linux 5.15.0-47-generic x86_64` Commented Sep 17, 2022 at 6:16
  • Thanks for well drafted solution. I upgraded the kernel to 5.19 it didnt work Commented Sep 17, 2022 at 9:35
  • Sorry that didn't work for one PC, I had to download and install a Realtek driver from GitHub, per ubuntuhandbook.org/index.php/2019/04/…. Sometimes, when the kernel is upgraded, though, I have to reinstall -- not ideal. Commented Sep 18, 2022 at 0:46
0

The solution to the problem is simple , after much research/circus and going through lots of solutions it was just sudo apt-get reinstall network-manager :-D

Thanks for the amazing post https://askubuntu.com/questions/1419194/no-wifi-adapter-found-in-ubuntu-20-04-ubuntu-22-04-lts

Thanks @chilli555

2
  • when i run "sudo apt-get reinstall network-manager" ... i get following message: "Reinstallation of network-manager is not possible, it cannot be downloaded."
    – TheGeeko61
    Commented May 7, 2023 at 14:41
  • try using sudo systemctl restart NetworkManager.service or equivalent service in ubuntu Commented May 9, 2023 at 5:10
0

I want to thank everyone on this forum because you provided very useful information for me to figure this out.

To fix the no wifi, no internet issue with software & updates and possibly even with mediaservers.

I have included a file that you can just download and replace the files and information manually.

I already tested it with 13 other people and its worked for them without issues.

file is mega.nz and this is the link:

https://mega.nz/file/06t2xBJZ#ef4IB6BSz4lr1lXm9nQr_STIIMwqwwacPDR1mv5CRrk

The file is 298kb since its only text files, for full transparency.

This information is on the instructions file in the zip. If any of you are hesitant of downloading/replacing and then modifying with the zip, follow the steps below.

Open directory as administrator Open USER LIB NETWORKMAN Folder Open folder NetworkManager.

Copy THIS NetworkManager files, INTO /usr/lib/NetworkManager You should have 14 files inside your own directory.

You have netplan, network and NetworkManager Folder

same concept as before, open the location /etc. Open directory as administrator Open /etc Folder Open folder netplan, NetworkManager, and network. (the folder network doesnt change from what i could see in the installation, but i saw more success with replacing all of the mentioned)

Inside /etc you will replace the pre-installed files, with the new ones. DO step by step so you dont mess it up, because you must change some information as stated below.(For your convenience, since most people are using different flavors of linux/debian/ubuntu, if you want to be safe, make a back up of your original files, and it this process does not work with you, replace the new ones with the originals)

/etc/netplan

#1. On the 00-installer-config.yaml file, access the file and make sure you change enp3s0 for the name of your ETHERNET device. as shown below:

network: ethernets: enp3s0: dhcp4: yes version: 2 renderer: NetworkManager

#2 On the 00-installer-config-wifi.yaml WILL ADDRESS THE NO WIFI ISSUE. access the file and make sure you change wlo1 for the name of your Wifi device. as shown below:

This is the network config written by 'subiquity'

network: version: 2 renderer: NetworkManager wifis: wlo1: access-points: MywifiName123: password: bignasty123 dhcp4: yes

If you fail to change this, then you wont fix the problem for ANY OF THE DEVICES.

/etc/NetworkManager/NetworkManager.conf, here the original files that come with the installer, show managed=false. The one below, it changes the code to managed=true.

[main] plugins=ifupdown,keyfile

[ifupdown] managed=true

[device] wifi.scan-rand-mac-address=no

  1. Same location different folder , /ect/NetworkManager/system-connections/ the file netplan-enp3s0.nmconnection, change the interface-name=enp3s0 to the name of your Ethernet device. If you have ipv6 capable device, you may change that to auto from ignore. The uuid will also be different to your device, so change that as well.

[connection] id=netplan-enp3s0 uuid=6effa1b1-280b-3785-9b52-c723b445fb3e type=ethernet interface-name=enp3s0 timestamp=1687929716

[ethernet] auto-negotiate=true wake-on-lan=0

[ipv4] method=auto

[ipv6] addr-gen-mode=eui64 method=ignore

[proxy]

ame location different file /ect/NetworkManager/system-connections/netplan-enp3s0.nmconnection netplan-wlo1-MYWIFINAME-2.0.nmconnection. Change the word wlo1 to the name of your wifi device. Do the same for the information inside that file. The uuid will also be different to your device, so change that as well. EXAMPLE BELOW: (honestly dont think the timestamp matters)

[connection] id=netplan-wlo1-MywifiName uuid=3152ed4b-995b-3833-b9d7-277f4d5c30c2 type=wifi autoconnect=false interface-name=wlo1 timestamp=1687929257

[wifi] mode=infrastructure ssid=Mywifiname

[wifi-security] key-mgmt=wpa-psk psk=password123

[ipv4] method=auto

[ipv6] addr-gen-mode=eui64 method=ignore

[proxy]

AFTER YOU DO THESE STEPS. Open terminal sudo netplan apply sudo systemctl sudo ip link set enp0s3 down sudo ip link set enp0s3 up sudo nmcli networking off sudo nmcli networking on

sudo systemctl restart NetworkManager or sudo systemctl restart NetworkManager.service

sudo nmcli networking off sudo nmcli networking on

AFTER ALL THESE STEPS, YOU HAVENT RESTARTED, BUT YOU WANT TO TRY IF ITS WORKING? PLEASE CHANGE SET wlo1/enp3s0 TO YOUR DEVICE NAME.

sudo nmcli dev set wlo1 managed yes sudo nmcli dev set enp3s0 managed yes

If all steps are completed, you may reboot sudo reboot

once your system boots up, if you dont have internet, terminal sudo nmcli dev set wlo1 managed yes

if you dont have ethernet,

sudo nmcli dev set enp3s0 managed yes

If you made it this far, and you still have issues, retract your steps and confirm your device id information is correct in all the files.

how do you do that?

nmcli

i suggest writting it down or copy pasting it for ease of access.

if your OS doesnt have net plan installed you may copy paste on terminal the following

sudo apt update sudo apt upgrade sudo apt -y install netplan.io

if you wish to remove it then: sudo apt-get remove netplan.io or sudo apt-get purge netplan.io sudo apt-get -y purge netplan.io sudo apt-get -y autoremove --purge netplan.io

THIS TOOK ME. 6 HOURS TO TROUBLE SHOOT, REBOOT, REPLACE, AND THIS WAS THE PERFECT EXECUTION TO GET WIFI WORKING AND ETHERNET.

THIS FIXES THE NO WIFI, NO INTERNET ISSUE WITH SOFTWARE & UPDATES, UNABLE TO DOWNLOAD/UPDATE USING GNOME-SOFTWARE, AND if your doing any VM or mediaserver, it helps with making sure your devices are GOOD TO GO as far as operation.

Hope this works for all like it did for me. (confirmed working for MINT, UBUNTU 19 TO 23.04, UBUNTU SERVER 20 TO 23, headless or with GUI, Arch and MATE) Its possible this might work on other flavors, but i have not tested them myself. Respectfully

2
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jul 2, 2023 at 23:12
  • apologies to the bot..... first time here, and i tried to be as precise and concise as possible. My response aims to fix 3 issues which i have encountered for over a few months and recently found the best way to go at it. Sorry for the confusion.
    – cto tore
    Commented Jul 3, 2023 at 1:32
0

follow this step to enable WiFi in Ubuntu22.04 go to show applications option and search for Additional drivers Additional drivers

under Ubuntu Software --> Download from --> Main Server

under Ubuntu Software --> Download from --> Main Server

Go to Additional Drivers tab --> Choose using BroadCom 802... option Additional drivers

apply changes oncne changes are completed you can see Wifi Drivers are enabled and connecte to WiFi

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .