I'm trying to send some files with around 2GB to my home server running Fedora 36. On my Laptop, I have Pop OS! 22.04. Both are directly connected to my router via Ethernet. Sadly, I'm getting errors which I cannot figure out how I get them fixed. I know that there are many posts out there with similar issues, but I haven't found a solution that works for me.

I tried running rsync, which results in this:

    413,040,640  15%   98.50MB/s    0:00:22  client_loop: send disconnect: Broken pipe

rsync: [sender] write error: Broken pipe (32)
rsync error: error in socket IO (code 10) at io.c(823) [sender=3.2.3]

Then I tried scp which gave me this:

client_loop: send disconnect: Broken pipe
lost connection

And rclone returns this and trying it again a bunch of times:

2022-09-17 15:44:57 ERROR : sftp://[email protected]:22/: Discarding closed SSH connection: read tcp> read: connection reset by peer
2022-09-17 15:44:57 ERROR : data.zip: Failed to copy: Update ReadFrom failed: connection lost

In general, I checked dmesg and journalctl without finding something that looked helpful to me. Here are things I already tried:

  • Limiting transfer speed
  • Checking if enough space is available (yes, there is more than 150GiB free)
  • Setting "ServerAliveInterval" and "ServerAliveCountMax"
  • Increasing timeout (the transfer usually fails in a few seconds, so does this even matter?)
  • zipping/creating tar and transfer that
  • using rsync 3.2.3 on both machines
  • writing on another drive that is on my server
  • running "dmesg | grep rsync" to see if something shows up. It returns nothing for me)
  • Forcing a memory purge with echo 3 > /proc/sys/vm/drop_caches
  • Also re-downloaded, flashed and re-installed Fedora 36.

Now you might think that there might be an issue with my laptop. But the odd thing is that I can transfer data without issue to/from a Pi4 running Raspberry Pi OS.

Would be awesome if somebody has any further ideas :)

Edit: Here is some information about my systems.

Home Server: neofetch output of my home server

Laptop: neofetch output of my laptop

Edit 2: Tried the transfer on a separate network (new router) with only the media server and my laptop connected (no WAN access). Without any duplicated IP, Hostname or MAC address assignments it won't work either

  • Is it possible that this is a network issue and not an OS related problem? Specifically, are any other devices using the same IP, hostname, or MAC address as your Fedora server?
    – JG7
    Sep 17, 2022 at 14:22
  • @JG7 the IP was assigned in my routers settings and is not part of the dynamic range. I also was not able to find any other device with the same IP, hostname or MAC address when looking in the router settings
    – MrMinemeet
    Sep 17, 2022 at 14:36
  • 1
    It seems to be a problem only in one direction (send disconnected x2 and read ...) have you tried the transfer in the other direction? Have you tried the transfer to/from a Pi4 with both machines? I had similar errors when the connection was interrupted: you can try the failing transfer with an (additional) open ssh connection (between the two computers). If ssh also freezes, it could be a network problem (cables, router port, router itself ...), if it stays active it could be a local hardware or software problem. Write down all the possibilities and rule out one by one. Good luck.
    – Hastur
    Sep 17, 2022 at 15:46

1 Answer 1


After @Hastur suggested to check transferring from and to my server from my laptop and Pi4 I found something. I tumbled accross the journalctl _COMM=sshd command for showing the sshd log, and there I saw the line ssh_dispatch_run_fatal: Connection from user user 192.168.1.XXX port XXX: message authentication code incorrect each time the transmission failed. Either I just missed it, or it didn't show up in the log file I looked at.

Anyway… I searched how to fix that issue now. After trying and googling a bunch, I came across this page: https://p5r.uk/blog/2014/ssh-corrupted-mac-on-input.html which coincidentally fixed my issue. I ran ethtool -K eth0 tx off rx off on my server and started a new transfer. Suddenly everything went through and after transferring around 50GiB it didn't throw that error again.

I'm guessing it works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .