0

I want to start a program at system startup. This program is called picam and it records surveillance video and audio.

The program works perfectly if I launch it from the terminal, but I want it to start automatically at boot with init.d, but it turns out that doing so has no sound.

This appears in the logs:

error: cannot open audio capture device 'hw:1,0': Device or resource busy
hint: specify correct ALSA device with '--alsadev <dev>'
warning: audio capturing is disabled

There seems to be a problem with alsa not starting automatically. I don't understand what could be happening.

In the application's forum, someone responded with this:

Notice that when using .asoundrc for pi user it has to be copied to /root/ or a /etc/asound.conf had to be made to replace the user .asoundrc, otherwise no sound!

https://github.com/iizukanao/picam/issues/31

I've tried creating a .asoundrc file with this, but I don't know if I'm doing it wrong:

pcm.record {
    typeplug;
    slave {
        cfm "hw:1.0"
    }
}

I have put it in /etc/ but when I reboot it still doesn't sound. Can you help me?

1
  • I had the same error because dbus.service wasn't started when calling from a systemd service - this answer shows how to enable it for a systemd service if that helps! - superuser.com/questions/1705484/…
    – Sam
    Nov 16 at 19:20

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.