This is Windows 10 with VirtualBox installed and Ubuntu virtual machine with Apache server.

Often CPU hangs on the Ubuntu virtual machine, taking up to 50% host CPU usage with no response at all, when nothing really is requested to work on. Once Ubuntu hangs, a hard restart of the virtual machine or saving the machine state and starting it will fix this.

The most common error that shows is like this: watchdog BUG: soft lockup - CPU#0 stuck for 23s.

I tried to spot something using linux top command with processes enlisted but for some reason when it hangs, top stops on showing just a few percents of CPU usage with nothing really to blame.

Here are errors

enter image description here


VirtualBox v 6.1.34
Ubuntu v 22.04 LTS
Windows 10 Pro v 21H2
  • 1
    Ubuntu emulated as a virtual machine with Apache server running. ... What does this mean? I have Ubuntu 22.04 running fine as a self contained VM using VMware Workstation on a Windows 10 then 11 host.
    – John
    Sep 21, 2022 at 16:26
  • Ubuntu emulated as a virtual machine with Apache server running Ubuntu VM is running an Apache server.
    – Esamo
    Sep 21, 2022 at 17:01
  • What do you mean by emulated virtual machine. Are you trying to nest machines?
    – John
    Sep 21, 2022 at 17:02
  • 1
    I would use ordinary terminology. In decades of running VMs I have not heard the term emulated VM. No meaning to the term. So then are you running the most recent version of VBOX? Did you install the most recent VBOX guest extensions in your Ubuntu VM?
    – John
    Sep 21, 2022 at 17:08
  • 1
    This is just a guess, because I'm not sure how VBox implements Symmetric Multi-Threading, but if its anything like VMware, you may want to try reducing the number of cores for the VM. I know it seems counter-intuitive but for multi-threaded applications where the VMs thread scheduler is scheduling threads across v-cores, the VMWare hypervisor will stall the threads until all the v-cores assigned to the VM are available, so if the vcores assigned are used by multiple VMs or the host, then the hypervisor can't get enough cores together at once to handle the VMs needs. Just a thought. Sep 21, 2022 at 18:10

2 Answers 2


Experiencing the same issue on vmware workstation 15 and 16 running ubuntu 22, found few references online

  1. https://communities.vmware.com/t5/VMware-Fusion-Discussions/quot-Soft-lockup-CPU-stuck-quot-on-Red-Hat-guests-after-upgrade/td-p/2875828
  2. https://communities.vmware.com/t5/VMware-Workstation-Pro/VMWare-Workstation-16-Pro-Ubuntu-22-04-1-VM-unresponsive-with/m-p/2930676#M177704

What worked for me initially was to reduce cpu cores to 2 and remove few packages I had installed using snap which I suspected to be related to the freeze (slack/firefox/brave). This worked for few days, now all of a sudden the freezes started happening again. I have the feeling that the unresponsiveness could be related as well to running GPU intensive applications on the host while the vm is up.


unmarking Accelerate 3D graphics of Virtual Machine Settings -> Display -> 3D graphics solved the problem. I have an NVIDIA GeForce MX450 on my host.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .