2

For a few of my apps, the preferences/apps control panel shows an incorrect (outdated) version. winget reports the same thing. For example, I have installed OBS Studio 28.0.2, but winget thinks it's 25.0.8.

Same thing with another software suite (Topaz AI): Three of the four apps show the correct version, but one app is reported as v6.0.0 (and winget proposes updating to 6.1.0) whereas I have installed 6.2.0...

I don't have more than one version installed (like one in Program Files and one in AppData or something like that), and I'm the only user on my machine.

Any idea how/why this happens and how to fix it?

2
  • You'll need to know what the different tools use to determine app version. What research have you done regarding this? Sep 28 at 3:44
  • According to the link @harrymc provided, winget uses the ARP (Add and Remove Programs) information, which is tied to the Registry keys. So it's a probably a problem on the developer's side for OBS/Topaz Gigapixel (the latter have confirmed this and suggested a workaround (using the full installer instead of the in-program updater), and this worked for both programs. Sep 29 at 16:07

1 Answer 1

3

You should complain to OBS Studio Support, although it might not be entirely their fault.

For example, the bug-report Some packages don't provide Version info, and winget upgrade constantly reports those #1255 relates that winget has difficulty reading the version information of some packages, so shows their version as "Unknown".

In your case, this same problem might result in the wrong version number found, although on the other hand it could be the fault of OBS Studio not having updated the version number in the package.

(Just to note that a user in that bug-report has solved his problem by moving on to Chocolatey.)

1
  • Running the full installers (as opposed to the in-program update mechanism) fixed the problem. Thanks for pointing me in the right direction! Sep 29 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.