0

Recently I noticed my Windows 10 on my Lenovo Lenovo IdeaPad Slim 1 81VT000MGE booting slowly (more than 1 minute). I compared some benchmarks with benchmarks from 2 years ago and this eMMC SanDisk DA4064 benchmark comparison was striking: CrystalDiskMark, left 2 years ago, right today

The slow Benchmark on the right is still the same when:

  • I boot from a USB Stick Windows
  • I delete 10GB data
  • 5 days later

I checked the drivers and they didn't update. Laptop was used 9 hours a day for 2 years with low to medium workload (Remote Desktop Client plus Offline things).

What does this mean? Failure imminent?

1 Answer 1

1

Check the SMART attributes of the disk for errors, If you don't have software for it, try Speccy, which will analyze the attributes and tell you if all are good.

If no errors are found, the SSD might be suffering from fragmentation, especially if it was heavily used during the last two years and if it's pretty full. It might be suffering from the same problem as is supposed to be solved by Wear leveling, that your data is smeared over almost all the disk blocks, which are not full, but that reading and writing involves accessing too many blocks.

The only solution here is to backup your disk and format it, which will issue the disk TRIM command to re-initialize all sectors. Returning the data will then result in the fewest possible blocks to contain the data.

Take a backup image of the disk, but also backup all your own data in a readable format. Don't use the Windows backup, but a third-party one. My favorite is AOMEI Backupper Freeware. I suggest creating an AOMEI boot restore USB in order to restore the data.

4
  • I'm not sure I'd agree with 'fragmentation' - as far as I'm aware that simply has no meaning on an SSD. If the drive is not crammed far too full, I wonder whether there's an option to run a manual trim. I have that option on my Mac 3rd party trim enabler, but idk the underlying command or whether there's a util for windows that could do the same thing.
    – Tetsujin
    Oct 1, 2022 at 15:05
  • 1
    @Tetsujin: If the firmware isn't too efficient, imagine a situation where all blocks are half-full, so that writing a block takes 2 reads and 2 writes. This theoretical case corresponds to the numbers in the answer (not saying that this is what happened).
    – harrymc
    Oct 1, 2022 at 15:12
  • I've been looking up spec on the drive. It's tiny 60GB & is benchmarking at 150 read 64 write, which is slow as all heck anyway. Maybe the faster results have some element of caching… or maybe the drive is crammed full, which wouldn't be surprising. notebookcheck.net/Sandisk-DA4128-SSD-Benchmarks.636533.0.html and harddrivebenchmark.net/…
    – Tetsujin
    Oct 1, 2022 at 15:15
  • Free space is 25-55% (as you can see in the question). eMMC has no SMART. Fortunately eMMC is still working (but with same slow speed). Oct 5, 2022 at 20:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .