After upgrading to v50 firmware in my Nokia 5800 xpress music phone.

I am not able to connect to ad-hoc wlan network in my laptop(Windows 7 OS).

I have a dialup internet connection and created wireless ad-hoc network to access the internet in my phone. But I am getting "invalid server name" in the phone and my wireless network access type in Windows 7 shows "no internet access".

I am able to connect to wlan infrastructure network using 5800 in my office. So my phone is working with wlan and I m able to access internet on it. BUT The problem is "dial up with ICS enabled" and "AD-HOC wlan network" in Windows 7.

Can anyone give some solution on it. Or can you provide a guide/tutorial to connect 5800 with adhoc network and dialup internet in Windows 7.

System: Windows 7
Dial up internet connection with ICS enabled.
Ad-Hoc wireless network with WEP
Nokia 5800 Xpress Music phone

Note: I have read other posts also and tried their solutions but didn't worked for me. the first solution is to bridge the network and access it. but how can I bridge the dialup and wlan netwok? second solution is manually configure IP and DNS addresses in phone. But what should I add as IP and DNS as my dial up and adhoc network have automatic addresses.

3 Answers 3


Create an adhoc connection with WEP encryption. On the last step of this setup it says:'Enable internet sharing?' Select it. Now your adhoc network is created and your internet connection is shared. On your phone go to Connectivity-Destinations-Internet-go to options and select "New access point"(Make sure the wlan connection on your pc is on)- it will search for available connections. Select your connection and enter the wep key. The access point will be added. Now, select the newly created access point and go to options and select "edit". Again go to options and select advanced settings, and select IPv4 settings. Since you use Windows 7, use this configuration:

phone ip address:

subnet mask:

default gateway: is ur laptop's wlan ip)

primary dns server:

secondary dns server:

Once you enter this, you are done. Enjoy surfing the internet on your 5800!!


Ok, the previous answer was a bit dodgy and may not work for everyone. It didn't always work for me either, so I came up with a very simple way to get it working.

This works on Windows 7.

  1. Under network and sharing centre, click "change adapter settings" on the left.
  2. Turn your wifi adapter on, right click it and choose properties.
  3. If there is a tab called sharing, click it and unmark the two checkboxes there. OK.
  4. Do the same for LAN adapter.
  5. Select both your Wifi and LAN adapter at the same time. right click one of them and choose bridge connections.
  6. Go to wireless network management and create an unprotected ad-hoc network and mark the "save this network" option so it won't disappear after you disconnect from it.
  7. That's it. First connect to the created ad-hoc network in windows and then with your phone.

Works like a charm for me. I have had no problems connecting to the internet, not even after restarting.

  • Thanks for answer, but this is not working as i have a cdma dialup internet connection in which i cant perform step 5. Do u have any clue how to do that?
    – Krunal
    Sep 7, 2010 at 13:49
  • would like to upvote ur answer but not enough rep. :(
    – Krunal
    Sep 7, 2010 at 13:51
  • Too bad then, sorry I couldn't help. Hope you will figure it out. It was a total pain for me but now when It's working, man it is awesome.
    – Dumbuser
    Sep 11, 2010 at 23:59

Use the other method I posted before trying this one. This one is too complicated and may not work for everyone.

Ok, this is what I did to get the internet sharing working correctly with my nokia 5800 connected to the ad-hoc network.

In my case I had all my adapters set to obtain the IP addresses and DNS addresses automatically.

NOTE: you have to do everything in this order or you will still get the "Invalid server name" error.

Before you start, your wifi adapter should be swithed off.

  1. click "adapter settings" under "network and sharing center"
  2. right click on an adapter and choose "properties", in the properties window see if you have a tab called "sharing" available, if you do then click it and make sure the 2 checkboxes are unmarked. Do this on all available adapters.
  3. under "wireless network manager" create the ad-hoc network and leave it discoverable and open(no wep or WPA just choose "open"). (You can try using a Wep or some other key. It hasn't worked for me though).
  4. Right-click your LAN adapter and choose "properties" then the "sharing" tab, mark the two checkboxes and in the window that opens when you click on the "settings" button, mark all of these.(WARNING: enabling internet connection sharing on all of these services can be dangerous on an unsecured wifi network you created in step 3. Experiment and leave unmarked as many unneccesary services as possible for the least amount of danger.)
  5. Switch your Wifi adapter on. Right-click your wifi adapter and select "properties". Double-click "Internet Protocol Version 4 (TCP/IPV4)". Now the "use the following IP address" and "use the following DNS server addresses" should be active. Also there should be addresses filled in the "IP address" and "subnet mask" fields. "Default gateway" and bothh DNS server addresses should be empty. That is how it was in my case. Now write in the "prefferred DNS server address" area the following address "" and ind the "alternate DNS server" area write "". (These are Googles public name server addresses ment to be used by anyone.) Click OK, and OK again in the next window.
  6. Click on your network icon in the taskbar and connect to the ad-hoc connection you created earlier. Search for wifi networks on your Nokia and connect to it. that's it, it should be working now. If you disconnect, turn your wifi adapter off or get the invalid server name error again. Do everything again from the start of the list. It happens sometimes.

If you get it working you can try different settings or different orders, I haven't had the time yet to work it out exactly what is neccessary so maybe there are some things you don't even need to that are on my list to get it working, but atleast this way I have gotten it to work 4 times in a row now.

  • Explain it in this answer. Or it will just be deleted as noise.
    – random
    Aug 24, 2010 at 1:07
  • ok will try it out and update u soon.
    – Krunal
    Aug 26, 2010 at 14:51
  • Thanks. I tried ur way.. but still getting "invalid server name", btw whts ur firmware ver of 5800? I also have "No Internet Access" status of newly created wireless adhoc network. do u have any clue?
    – Krunal
    Aug 26, 2010 at 15:11
  • My firmware version is the latest. ver 51.0.0.... something, released in august 2010. Ill add another answer aswell. This one is. Much simpler. And should work 100%.
    – Dumbuser
    Sep 2, 2010 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .