I was trying to install current drivers for my NVIDIA so software can use the power of GPU.

sudo apt install nvidia-driver nvidia-cuda-toolkit

I've ended up with 520.* drivers and CUDA 11.8 so I was happy as I couldn't finish the installation for them yesterday (can install only 470.* and got some error messages: one time from hashing software and other time from nvidia-smi about mismatching driver version). I've got also issues with double monitor setup (I couldn't end up with configuration that second monitor is recognized and CUDA capabilities available).

So now I have 520.* drivers with CUDA 11.8. I'm booting to Linux (Kali, Debian), unlocking the drive (I can use backspace to delete passphrase characters) and when GUI kicks in with login prompt - no input is accepted. Typing on keyboard doesn't do anything, Ctrl+Alt+Del neither. Both notebook and standalone keyboard (via USB). Mouse cursor doesn't move.

How can I troubleshoot that? I was working with removing and installing nvidia-* packages and xserver-* packages so many times over past day I would like some more experience input.

Ok I've searched for logs as @Robidu pointed out, got some screens. After that I've removed nvidia-drivers and nvidia-cuda-toolkit packages. Now when I boot up I'm seeing following error on the console that it can't start Light Display Manager.

Screens are here: https://drive.google.com/drive/folders/1-GFatc1HOKuBxL0RtJHq7_bgwF5J8Aly?usp=sharing

I've installed the cuda package downloaded directly from nvidia site, as @hex described - results in the original error: I stuck at GUI login with both keyboard and mouse not responding.

So I have purge --autoremove metapackages kali-desktop-core, kali-linux-core and reinstalled them again - to no avail. At this point I'm going to try reinstall the system partitions (I have home at separate one).

I've reinstalled the system leaving my /home and /boot intact. Then I've followed the guide on restoring the /etc/crypttab. Still got the same issue on GUI. But this time I've switched to terminal view and started entering volume password. After 9 seconds my screen was flooded with following, repeated line:

[9.7XXXXXX] nouveau 0000:01:00.0: mc: intr 00000040

where XXXXXX stands for fractions of second. I'm too tired for today and gonna check later what that nouveau is.

  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer.
    – Community Bot
    Oct 4, 2022 at 20:08
  • @Community what do you mean? Issue is clearly explained both in title and body of the message. I have no mouse/keyboard input on GUI login prompt. I suspect some issues with xserver. Oct 4, 2022 at 20:26
  • Have you had a look at the logs to find out whether or not anything is amiss? Maybe /var/log/X.org.log, /var/log/messages, /var/log/kern.log, /var/log/daemon.log, etc. If there's anything related to that, please edit your findings into your question (not necessarily the entire logs but the snippet(s) pertaining to the issue) as it would help narrow down the problem.
    – Robidu
    Oct 5, 2022 at 11:07
  • @Robidu updated question Oct 10, 2022 at 6:09

2 Answers 2


Ok, so after couple days I've finally been able to track down the issue due to findings in EDIT3. Kudos to author of this answer.

Problem occurs because of GPU drivers in integrated+dedicated (NVIDIA) hardware environment. Issue no longer appears when following kernel boot command is placed:


Temporary change

One of necessary methods to do persistent change

Easiest is to be done by highlighting the Linux boot option in GRUB menu, press E and then locate the similar line

linux /vmlinuz ... root=... ro quiet splash

Add the beforementioned command.

linux /vmlinuz ... root=... ro quiet splash nouveau.modeset=0

Press F10 to continue booting.

Persistent change

Now you should be able to boot and login to system. To make it persist between boots, edit following file

sudo nano /etc/default/grub

and add that nouveau.modeset=0 command to GRUB_CMDLINE_LINUX_DEFAULT. Then run

sudo update-grub

Turns out installing via apt get with

apt get install nvidia-driver nvidia-cuda-tools

installs the wrong graphics driver for nvidia cuda tools.

I had to go to the dev https://developer.nvidia.com/cuda-downloads and download that version after your purge nvidia-tesla*

after completing the install of cuda tools this version installs the correct 510 graphics driver at the very end of the install... so yeah turns out using apt to install the drivers from the repo was the problem.. try the link instead :)

  • 1
    I did that one time and nvidia-smi shows the 520 drivers indeed, but my HDMI connected display wasn't recognized. But I definitely didn't clear the nvidia-tesla-* packages back then. Oct 6, 2022 at 17:04
  • updated question Oct 10, 2022 at 6:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .