1

I have an old WD My Passport 2 TB USB 3 external hard disc. It has worked fine for 10 years, but for the past week, it doesn't even show up in Disk Management on Windows or Disk Utility on Mac, not even as an unformatted hard disc. The LED keeps blinking on and off in a regular pattern, not the irregular pattern indicative of data being accessed. I don't hear a clicking noise.

It does show up as a USB device in Device Manager, so my understanding is that the computer is able to talk to the controller in the disk, but the controller is not able to talk to the disk itself.

I know the cable is not the problem, because another disk works perfectly with it. I know the OS or the computer are not the problem because I tried two different computers, a Mac and a Windows. I applied all software updates, and rebooted, just to be sure. I tried connecting it to the laptop directly, and via a powered USB hub, which made no difference.

After this saga began, it did show up once on my Mac, but was able to read data at only 900 KB/s. After an hour, the speed increased to the usual 30-40 MB/s and it ran fine after that. But the next time I plugged it into the Mac, it didn't work.

WD support has been clueless, as expected. Their diagnostics app doesn't even detect the disk.

Is there anything I can check before I throw away the hard disk?

I don't have valuable data on it, so this question is not about data recovery.

3
  • 1
    You can check SMART, but do you really want to trust this drive to hold any data in the future? Oct 21, 2022 at 4:34
  • I agree with @mashuptwice: you can check the SMART report using CrystalDiskInfo on Windows, but the drive has obsviously has obviously a mechanical/electrical problem as it seems it doesn't even spin up most of time. It's time to retire it.
    – PierU
    Oct 21, 2022 at 6:27
  • @mashuptwice The computer says that SMART is not supported by the disc. But I agree with you and with PierU to retire the disk. Thanks. Oct 21, 2022 at 8:27

1 Answer 1

-1

My own WD Passport suddenly yielded a "no access" error. I could see the drive in File Explorer but clicking upon it did not expand its contents. Chkdsk declared "no access." Changing the drive letter did nothing. Drive status, driver both was reported good by WD Utilities. Quick test was passed. Complete test stopped at 10%. But the solution for me to get access was to right click on the drive icon, choose properties. Then click the security tab. Click Advanced. Then I discovered I had did not have Authenticated User listed! I added it and gave it full permissions. It added such to the files. I also clicked the box to adding the child inheritances. That took a few minutes to complete after clicking apply. I subsequently could access all my files and folders on the passport drive again. If this is no assistance to you, there are other options for the "no access" problem for a paasport drive on the Stella data recovery site and on the Easeus site if you search google and include those specific terms and Stella or Easeus.

1
  • 3
    Reads like clumsy spam. Usually I'd regard Stellar and Easeus website unreliable, most of their posts and articles read like AI generated, generic content. Sep 5 at 14:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .