Last night windows updated itself with some kernel drivers related patches and as a result today morning my Windows 7 won't even boot in safe mode.

It tried to repair itself, but no good

Root cause found:
- - - - - - - - - - - - - - - -
a patch is preventing the system from starting

Repair action: System files integrity check and repair
Result: Failed. Error code = 0x4005

I know which updates it installed, particularly I want to remove KB2160329 and KB981852. All I can get is Console...

Any ideas how to remove those updates?

  • You've fortunately got plenty of answers addressing this issue. So I'll leave here my own bit of slightly unrelated recommendation: Despite general advise, do not let Windows automatically update your system. Try to establish a monthly routine, or something similar in which you do manual updates through Windows Update. It won't entirely remove problems like this, but will greatly reduce the odds of them happening again. You will still be able to keep an updated system (to the month) and a more stable one. Do not necessarily trust automatic updates to be bug free. They aren't. – A Dwarf Jul 11 '11 at 22:41

Faced that issue today, my way to solve it:

  1. Start up with F8
  2. Run in safe mode
  3. Windows should uninstall dubious KB2160329
  4. Make sure that you will restart back to safe mode
  5. Restart to normal mode
  6. Windows will revert the update here as well

Hope that helps..

By the way, I've spotted that in C:\Windows\System32 I have now the 6.1.7600.16585 version, while the latest available in the system is 6.1.7600.20738 (check C:\Windows\winsxs). Might it be some case of signature overwriting?

| improve this answer | |

Just had this problem today after a BIOS update. The update process changed the SATA mode from ACHI to IDE. This prevented Win7 to start. I tried to go in recovery mode or use the installation disk without any success.

Then I changed back the SATA mode to ACHI and all worked back without any issue. Just want to post in case this can help anyone to have back a working system ASAP.

| improve this answer | |

A quick Google search shows a few people with this same issue in Windows 7. The fix seems to be restoring backup copies of corrupted registry files.

Excerpted from a conversation on social.technet.microsoft.com:

"I first booted from the Windows 7 install disc to get to the system recovery console. I then selected Command Line. From there, I had to change from the X: drive to the C: drive by typing "C:". I then typed "cd\ windows\system32\config" to get to the registry file directory. By typing "dir" I could see that two of the five hive files (default, sam, security, software, and system) had recent copies with an "rmbak" extension: default.rmbak and software.rmbak. I then executed the following commands:

ren software software.bak
copy software.rmbak software

ren default default.bak
copy default.rmbak default

I would suggest you execute the "ren" then "copy" commands as above for any other hives that have "rmbak" backups with the same date/time stamp. This ensures your registry remains in sync. You can now reboot and see if your computer comes up.


Some variation on that fix might be just what you're looking for.


| improve this answer | |
  • I saw that one, since I'm also googling from the morning :( Unfortunately this one didn't help. I guess over the night it installed some update which caused this situation. But how to find out which one and get rid of it, not an easy question. – Pablo Aug 12 '10 at 1:35

You're apparently not the only one with this problem. It's apparently KB981852 causing the problem.



Also, you might try rebooting with "Last Known Good Configuration". WHen rebooting, hit F8 to get the boot menu. On the Advanced menu choose "Last Known Good Configuration". As long as you haven't logged on since installing the patches (and since you can't boot, that seems to be a safe assumption in your case), Last Known Good should get you going.



| improve this answer | |
  • I should move to os x apparently once I fix this. As MS forums are quite slow I would appreciate if anyone here could give some ideas. All I need is just boot once, even without drivers, so I can backup some stuff which is critical to me. – Pablo Aug 12 '10 at 2:37
  • I've tried pretty much everything that is possible. Last Known Good configuration will also take me to repair, with the message that automatic repair is not possible. BadPatch and A patch is preventing the system from starting all I was able to get from the logs. – Pablo Aug 12 '10 at 2:45
  • 1
    @Michael, try booting with a Linux Live CD like Ubuntu, and do your backup with. – Michael B. Aug 12 '10 at 2:49
  • 1
    @Michael B.: Like I said in my "double post", I need to run a software in broken OS to produce backup, it's not just raw files, but cryptographic data. – Pablo Aug 12 '10 at 3:05

My problem was the BIOS. The computer had not been turned on for over a year. When setting up the BIOS, I left it at the default which was not correct.

Changed back to SATA mode ACHI. Booted up fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.