2

I recently installed Linux, and I've noticed sometimes it freezes for about 5 seconds, and then it resumes normal operation.

Looking at the logs with journalctl I saw this message appeared at the same time that the laptop froze:

nouveau 0000:01:00.0: DRM: failed to idle channel 0 [DRM]

I've mostly noticed this when using Chrome. I tried disabling Use hardware acceleration when available in Chrome and the issue persisted.

Now I've switched to Firefox, and the issue happens less often now, but still happens.

Does somebody know what this issue is about and how to fix it?

My setup:

  • Asus ZenBook UM5500Q
  • Ubuntu 22.04.1
  • Window Manager: KDE Plasma
  • Processor (from lscpu): AMD Ryzen 9 5900HX with Radeon Graphics
  • Graphics card (according to lspci below): GeForce RTX 3050 Ti Mobile

And some other info:

$ sudo lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Renoir/Cezanne Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Renoir/Cezanne IOMMU
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Renoir PCIe Dummy Host Bridge
00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Renoir PCIe GPP Bridge
00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Renoir/Cezanne PCIe GPP Bridge
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Renoir PCIe Dummy Host Bridge
00:02.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Renoir/Cezanne PCIe GPP Bridge
00:02.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Renoir/Cezanne PCIe GPP Bridge
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Renoir PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Renoir Internal PCIe GPP Bridge to Bus
00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Renoir Internal PCIe GPP Bridge to Bus
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 51)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Cezanne Data Fabric; Function 7
01:00.0 3D controller: NVIDIA Corporation GA107M [GeForce RTX 3050 Ti Mobile] (rev a1)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
03:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)
04:00.0 Non-Volatile memory controller: SK hynix Gold P31 SSD
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne (rev c4)
05:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Renoir Radeon High Definition Audio Controller
05:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
05:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Renoir/Cezanne USB 3.1
05:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Renoir/Cezanne USB 3.1
05:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
06:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 81)
06:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 81)

1 Answer 1

2

You should install the Proprietary NVIDIA driver. The open source driver nouveau does not support all features on that recent GPU you've got, such as dynamic reclocking and 3D support. This is indicated on Nouveau's main page.

To install the proprietary driver on Ubuntu 22.04.1, follow these instructions:

Ensure the Ubuntu installation is up to date:

This ensures minimal conflicts when installing kernel and driver packages.

sudo apt update && sudo apt upgrade

I recommend rebooting thereafter before continuing with the next step:

sudo systemctl reboot

Then proceed to install the drivers via the ubuntu-drivers utility. Invoke it via:

ubuntu-drivers devices

To see information about your GPU and the recommended driver to install.

To install the driver package recommended by ubuntu-drivers, run:

sudo ubuntu-drivers autoinstall

And be sure to reboot when done, then retest.

Extra notes:

If you need H/W based decode in Firefox with an NVIDIA GPU, build and install the NVIDIA VAAPI driver back-end from here.

1
  • 1
    I couldn't install the driver using the above procedure (the ubuntu-drivers install script said All the available drivers are already installed.). But I managed to install it by first installing Software Updater (doesn't come by default with Kubuntu), and then in the Additional drivers tab I selected the recommmended driver. Thanks, this solved my issue!
    – DWilches
    Nov 7, 2022 at 19:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .