I'm attempting to upgrade from Windows 11 21H1, build 22000.1165 to Windows 11 22H2, Windows Update does not offer the upgrade, and when I try installing the update manually, I receive an error message that links to the documentation for Windows safeguard hold ID 41332279, titled "Some installed printers might only allow default settings".

Screenshot of the Windows 11 Setup error message

This error persists even after removing all printers and associated printer drivers in the Print Management console. The only printer drivers remaining are the x86 and x64 versions of the "Microsoft enhanced Point and Print compatibility driver". When I try to delete those drivers, I receive an error message that states "The selected driver cannot be deleted. The specified printer driver is currently in use."

Screenshot of an error from the print management console

I tried deleting those drivers with the Print Spooler service stopped, but I received an error that indicated that the Print Spooler service must be running.

Screenshot of the print spooler error message

I even tried deleting the registry key at HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-3\Microsoft enhanced Point and Print compatibility driver and rebooting, but the key was automatically recreated after the reboot.

Screenshot of regedit

At this point I thing I'll need to reinstall Windows completely, which I really don't want to do.

Any suggestions?


1 Answer 1

  1. Stop the Print Spooler service.
  2. Open an administrative command prompt.
  3. Remove everything in your windows/system32/spool folder with the command rmdir /s %WINDIR%\system32\spool

This completely removes the printers from the system. Start spooler, Try the windows 11 installer again.

Further reading about the 41332279 states that a fix is currently in progress. MS say "We are working on a resolution and estimate the safeguard will be removed in mid-November."

  • @JohnnyVegas I think describing how to do this through the GUI might be better; iirc you can, and it's less likely to result in doom and destruction.
    – wizzwizz4
    Nov 7, 2022 at 13:15
  • 5
    I've barely used Windows for decades, but surely rmdir /s /q %WINDIR%\system32\spool works and is safer?
    – Auspex
    Nov 7, 2022 at 14:08
  • Didn't expect this question to blowup! @wizzwizz4 If you can tell me how to open an explorer window with administrative rights as easily as 'open an administrative command prompt' I would like to know! I guess you could create a shortcut to explorer and then go to advanced, and then click Run as administrator, and then browse to the spool folder then select all & delete - It would work but then it's not as simple? Nov 7, 2022 at 17:36
  • 1
    @JohnnyVegas You don't need an Explorer window with administrative rights. If you don't have permission to delete the files, it'll say "you can't do that" and then you can get a UAC prompt by clicking the button labelled… I think "Continue"?
    – wizzwizz4
    Nov 7, 2022 at 18:04
  • So how would you explain doing it through the GUI? Nov 7, 2022 at 22:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .