How do I disable the Ctrl + A keyboard shortcut in KeePass?

This is "ą" in Polish and I use it very often. I've dug into options and found nothing. It's annoying not being able to type normally with KeePass open.

  • 4
    The even more annoying thing about alt-a is, it's default behavior is copy-paste and confirm (enter) the currently selected login and password to whatever text-field the cursor might be in. So, for instance, while chatting with KeePass on you end up sharing your passwords with your chat-mates. Totally annoying. Thank you for asking this. – mmm Jan 12 '14 at 16:25
  • 1
    why do you talk about ctrl+A but then answer about Alt+A? – phuclv Feb 14 '17 at 8:37
up vote 11 down vote accepted

Cornelius'answer from Aug 18 '10 is almost two years old.

Here is the solution for KeePass 2.21.

Go to Tools/Options/Integration/System-wide hot keys/Global auto-type and clear the shortcut already written there (Ctrl, Alt + A); it will change to None. There you have it!

enter image description here

To change Alt + A keyboard shortcut go to:

Tools > Options > Advanced > Auto-type (button at the bottom)

and change key combination here.

screenshot

Remaping "ą" is obviously not a solution. Go to Tools > Options, then Advanced tab and click Auto-Type button. You may disable it or change.

Generally it is bad idea to register as a global shortcut any combination of Ctrl+Alt.

Autohotkey will be able to help you remap the "ą" to another key combination that won't interfere with KeePass.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.