1

I want to assign an extension action to Alt + T but even though it's set properly, Firefox is still overriding it and showing its own mini menu instead of activating the extension action.

enter image description here

How do I disable this behavior?

1 Answer 1

0

Firefox is still overriding it and showing its own mini menu

That's because Firefox uses alt as a shortcut to open the menu bar and alt+t will open the tools menu.

There are a couple of potential fixes.

How to disable menu popping up when I press ALT key

You can set the ui.key.menuAccessKeyFocuses pref to false on the about:config page to prevent opening the menu when holding down the Alt key. This may require to close and restart Firefox.

ui.key.menuAccessKeyFocuses = false 

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Source: How to disable menu popping up when I press ALT key

If you still wants access to the menu bar you can change the shortcut uses to open it:

How to disable menu bar navigation via alt+_ key shortcuts?

set ui.key.menuAccessKey = 17 on the about:config page. This makes the menu bar work with Ctrl+Shift.

Source: How to disable menu bar navigation via alt+_ key shortcuts?

2
  • Amazing, I didn't even know the popup was coming from the menu bar since I thought it was inactive when hidden. I just thought it was a random quick access menu of sorts. Nov 12, 2022 at 5:13
  • Just an update, ui.key.menuAccessKeyFocuses set to false with a browser restart did not work. What DID work was setting ui.key.menuAccessKey to 0 Nov 12, 2022 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.