My MacBook Pro's Trackpad shows an annoying behavior in the last few days. I think the only relevant thing that changed is the firmware for the Trackpad. An update has been distributed via Software Update a few days ago.

Sometimes when i click somewhere the Trackpad won't recognize the mouseup, i.e. hold the click on its own. Clicking again seems to stop the holding and issue a new mousedown, but then again, no mouseup

I.e. when i click on a file on the desktop the file will be dragged. But i can't stop dragging! Clicking in a browser or text document will select the text/images.

Did anyone notice similar behavior? Any ideas or fixes?

  • mine seems to work fine... This is about just trackpad problems in general but it wouldn't hurt to take a look reviews.cnet.com/8301-13727_7-20012617-263.html. At least I think that's the update in question, I'm not sure. – Vervious Aug 13 '10 at 5:51
  • Thanks for the tip. The article isn't very helpful though. instead of describing how to find the settings file (which won't turn up) a filename would have been a good idea. I'll try to find the settings file myself. – lajuette Aug 13 '10 at 7:32
  • check my answer to the similar issue... I don't think it has to do with the update, as my mac is also all up to date and I never had such issue. superuser.com/questions/193383/… – cregox Oct 5 '10 at 16:15
  • I know your issue, i pointed you over here in a comment =) – lajuette Oct 5 '10 at 18:18
  • As an aside: hitting Esc will probably allow you to stop dragging. – Arjan Nov 28 '10 at 10:18

The real culprits are the Trackpad Screw and Button in case of Aluminum Bodies.

If your trackpad button is not loud enough when clicking or not making a release sound, it may be too tight and clicks on its own and sticks to its hole with gravity or any kind of force, you should loosen it. (I did this just ten minutes ago and it worked.)

  • Remove the battery cover.
  • Remove the battery.

  • There is a screw looks like a 3 pointed star. (I did somehow managed to loosen it with a little Slot Screwdriver by manipulating the angle and force)

  • Turn it counter-clockwise a little bit.

  • While loosening, open the case a little bit, click-hold a while and release the trackpad button and listen to the trackpad whether its giving the click sound for both clicking and releasing.

  • There should be both initial click sound and release click. If it is not giving a release click sound loosen it again.

PS : If you're using a Mouse and don't mind deactivating Trackpad, you can go to System Preferences → Universal Access → Mouse & Trackpad and make the appropriate choice.

  • Are we talking about Unibody MacBooks? They don't have Battery covers. Only bottom covers, which are secured by screws. – lajuette Jul 21 '11 at 18:55

On my 4 year old white 13" MacBook (first revision, A1181, Core Duo) this started to occur for about 10 minutes after waking it from sleep. The trackpad button (which is a separate button on that model) would not "click" (so: was really pressed all the time). After the MacBook was heated up a bit things were fine though. And removing the battery fixed the problem right away. So it seemed there somehow was too much pressure on the trackpad while the machine was not heated up yet.

My current battery looks fine; an earlier one was swelling and looked a bit like the deformed one in Macbook Trackpad Not Working – Battery May Be To Blame but at that time I did not have the trackpad problems yet.

First, I partly fixed it by removing a little grey rubber sticker below the battery. That sticker was sitting right on the little round metal plate (which I guess is the actual button) where someone else put some additional material to apparently get more pressure in An Origami solution to the Apple MacBook TrackPad “squishy” Button Problem. I'm not sure if my MacBook had that sticker when I first purchased it; the sticker is not in the pictures in the ibloggedthis.com article, but I had my top case replaced some years after purchasing it.

The grey rubber sticker is partly visible on this ifixit.com picture:


After a few days, I noticed things were still not 100%. I guess it was a combination of dirt and the battery being in place. Some people report that dragging some folded piece of paper below the trackpad button might clean things. However, one cannot only clean underneath the button itself, but also in the opposite direction, between the button and the top case. The button is actually larger than one can see: the lower part of the button extends a bit to the left, right and front, underneath the top case. On my Mac, dragging a piece of paper a few mm underneath the button had no effect, but doing the same underneath the top case (while keeping the button pressed down) finally made it click like it was brand new.

  • My MacBook doesn't have a Battery compartment that i can open. It one of these Unibody-MacBooks. – lajuette Nov 28 '10 at 14:25

I have this problem, too. Happens once in a while and it is infuriating. My only solution is to reboot (I have tried logging out and back in, but that doesn't help. I haven't tried closing the lid and re-opening, as per a previous post).

  • Does pressing ESC help? (see Arjan's comment on the question) – lajuette Nov 28 '10 at 14:26
  • 1
    I was only referring to stopping dragging, @lajuette. Hitting Esc would not stop my Mac from thinking (well, knowing) the trackpad button is pressed, but at least one can stop erroneous (and dangerous) drag actions... – Arjan Nov 28 '10 at 15:09

This happens to me sometimes! The only solution I have found thus far is to restart, which is really annoying. I always keep my Macbook on and just put it to sleep when I'm not using it.

  • Any idea what triggered this behavior? – lajuette Sep 9 '10 at 22:50

I just had this problem and I think I solved it. If you have a Magic Mouse make sure it is turned off and disconnected. Mine was in my computer bag a

  • Half of your answer seems to have fallen off the end... – Greenonline Aug 3 '20 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.