13

I have Windows 11 and I had WSL working fine, until I had to do a PC Reset and now trying to install it again from scratch. This is what I get now (after multiple WSL installation attempts):

PS > wsl --install
Windows Subsystem for Linux is already installed.
The following is a list of valid distributions that can be installed.
Install using 'wsl.exe --install <Distro>'.

NAME               FRIENDLY NAME
Ubuntu             Ubuntu
Debian             Debian GNU/Linux
kali-linux         Kali Linux Rolling
SLES-12            SUSE Linux Enterprise Server v12
SLES-15            SUSE Linux Enterprise Server v15
Ubuntu-18.04       Ubuntu 18.04 LTS
Ubuntu-20.04       Ubuntu 20.04 LTS
OracleLinux_8_5    Oracle Linux 8.5
OracleLinux_7_9    Oracle Linux 7.9


PS > wsl --install Ubuntu-20.04
Installing: Ubuntu 20.04 LTS
Ubuntu 20.04 LTS has been installed.
Launching Ubuntu 20.04 LTS...
PS > wsl list
Windows Subsystem for Linux has no installed distributions.

Use 'wsl.exe --list --online' to list available distributions
and 'wsl.exe --install <Distro>' to install.

Distributions can also be installed by visiting the Microsoft Store:
https://aka.ms/wslstore
Error code: Wsl/Service/CreateInstance/GetDefaultDistro/WSL_E_DEFAULT_DISTRO_NOT_FOUND

If I run the Ubuntu app, I get:

Installing, this may take a few minutes...
WslRegisterDistribution failed with error: 0x80370114
Error: 0x80370114 The operation could not be started because a required feature is not installed.

Press any key to continue...

Under "Turn Windows features on or off" I have enabled:

[x] Virtual Machine Platform
[x] Windows Hypervisor Platform
[x] Windows Subsystem for Linux

By the way, I only turned on "Windows Hypervisor Platform" later, as an experiment. I saw answers on GitHub and elsewhere related to vmcompute.exe but I don't have that on my system, do I need to install it, and if so, how?!

PS > ls C:\Windows\System32\vm*


    Directory: C:\Windows\System32


Mode                 LastWriteTime         Length Name
----                 -------------         ------ ----
-a----        07/05/2022     06:20          50528 VmApplicationHealthMonitorProxy.dll
-a----        21/11/2022     19:41          79896 vmbuspipe.dll
-a----        07/05/2022     06:20         270336 vmdevicehost.dll
-a----        07/05/2022     06:20          87400 vmictimeprovider.dll
-a----        07/05/2022     06:20         487424 vmrdvcore.dll

Even though already enabled, also tried the accepted answer on a similar question, but no difference:

PS > dism.exe /online /enable-feature /featurename:Microsoft-Windows-Subsystem-Linux /all /norestart

Deployment Image Servicing and Management tool
Version: 10.0.22621.1

Image Version: 10.0.22621.819

Enabling feature(s)
[==========================100.0%==========================]
The operation completed successfully.

PS > dism.exe /online /enable-feature /featurename:VirtualMachinePlatform /all /norestart

Deployment Image Servicing and Management tool
Version: 10.0.22621.1

Image Version: 10.0.22621.819

Enabling feature(s)
[==========================100.0%==========================]
The operation completed successfully.

So what is the solution here? The forum answers didn't help me, and the MS documentation sounds like all that's needed is a magic wsl --install.

System information:

Edition Windows 11 Home
Version 22H2
OS build    22621.819
Experience  Windows Feature Experience Pack 1000.22636.1000.0

Any suggestions are appreciated, otherwise I'll share the solution I find later. Going to install some updates now, and will see if that helps.

8
  • Try to install Ubuntu from the Microsoft Store.
    – harrymc
    Nov 21, 2022 at 19:18
  • Uninstall all three optional features then after a reboot, run wsl --install as an Administrator. Also, based on my 1 minute of research, vmcompute.exe is Hyper-V Host Compute Service, which is NOT required for WSL2. Besides since your using Windows 11 Home it's impossible to enable on your edition of Windows. This might be helpful
    – Ramhound
    Nov 21, 2022 at 19:21
  • @harrymc had also tried installing from the Microsoft store, same thing. Turns out all that was needed was an update. Bit silly, but pretty sure when I checked the settings just a few hours earlier it told me it that Windows was up-to-date.
    – Nagev
    Nov 21, 2022 at 19:29
  • Yes, I did run it as administrator before. Don't know if vmcompute.exe is required, but it showed up after I installed the latest updates. Anyway, all sorted with the updates, thanks.
    – Nagev
    Nov 21, 2022 at 19:34
  • I had to install Virtual Machine Platform. Windows Subsystem for Linux was already installed
    – neildt
    Feb 7, 2023 at 11:32

5 Answers 5

2

Installed the Windows updates, and after restarting the Ubuntu installation resumed. Now WSL works!

And now I have:

PS > ls C:\Windows\System32\vmcompute*


    Directory: C:\Windows\System32


Mode                 LastWriteTime         Length Name
----                 -------------         ------ ----
-a----        21/11/2022     19:41         796000 vmcompute.dll
-a----        21/11/2022     19:41        4158848 vmcompute.exe
-a----        07/05/2022     08:16          42344 vmcomputeeventlog.dll

Really simple, but I am glad, and hope it's helpful to someone.

4
  • I am shocked you now have Hyper-V Host Compute Service installed, since it requires Hyper-V, which cannot be enabled on Windows 11 Home. The issue likely was you had a pending update ready to be installed, or the optional feature was ready to be installed, or like most computer problems just rebooting helped.
    – Ramhound
    Nov 22, 2022 at 6:20
  • 1
    Don't think I can create virtual machines with it though... I had restarted at least once after enabling WSL. Agree, I think it's the updates + restart that did it. But yeah, rebooting is always a good idea. I had checked and saw no pending updates after the Windows 11 reinstall done by the reset. And then I saw the pending update after I finished crafting the question and was about to press submit!
    – Nagev
    Nov 22, 2022 at 9:32
  • If you actually have Windows 11 Home you cannot create Hyper-V VM(s).
    – Ramhound
    Nov 22, 2022 at 9:52
  • 1
    Thanks this worked for me having found very similar things to what you described. In my instance I am on Windows 11 Pro, but I still didn't have vmcompute in the right location (it was in some of those winsxs subfolders which I think relate to the update process). In any case, I thought I'd add here that the only update available for me at the time (having tried all of the other things you tried and rebooted several times) was KB5023778 listed as optional. Update history says it failed to install so that's weird but I now have vmcompute in c:\windows\system32 and Ubuntu launched successfully. Apr 3, 2023 at 1:13
1

Just in case someone else finds their way here via a search I thought I'd add the things I needed to do in addition to most of those mentioned, as this seems to be the most information-rich question of the many dupes.

When I was stuck at the 0x80370114 error, I needed to uncheck all three of Virtual Machine Platform, Windows Hypervisor Platform and Windows Subsystem for Linux options in Turn Windows features On or Off. Then click Apply, skip the suggested restart, then turn them all back on again, then Apply, this time with a restart.

After doing that, I then hit the 0x80370102 error, which was resolved for me by re-setting the hypervisor launch type to Auto (which I had turned off during a much earlier bout of desperate troubleshooting):

bcdedit /set hypervisorlaunchtype Auto

After a restart, WSL commands were working as expected.

1
  • Or, if you don't have those three already, enable them.
    – OrangeDog
    Aug 5, 2023 at 15:35
0

I had to enable VM utilization in BIOS. Even though it should not be needed for WSL2, I also enabled HyperV.

Then it worked.

2
0

So, what's helped for me was removing Hyper-V, Virtual Machine Platform and uninstalling everything regarding WSL. Then restart, add C:\Windows\System32\vmcompute.exe and C:\Windows\System32\vmwp.exe to Exploit protection setting:

  • Override System Settings
  • On
  • Use Strict CFG

After that running administrative command prompt type wsl --install. It's gonna install only WSL2 and Virtual Machine Platform, and hopefully successfully install Ubuntu.

-1

I have the same situation.

PS> wsl --install -d Ubuntu
PS> wsl list

It reports an error at wsl list commands.

You can try:

PS> ubuntu
Installing, this may take a few minutes...
Please create a default UNIX user account. The username does not need to match your Windows username.
For more information visit: https://aka.ms/wslusers
Enter new UNIX username: xxx
New password:
Retype new password:
passwd: password updated successfully
Installation successful!
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

Welcome to Ubuntu 22.04.1 LTS (GNU/Linux 5.15.79.1-microsoft-standard-WSL2 x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

This message is shown once a day. To disable it please create the
/home/xxx/.hushlogin file.

Exit after entering the subsystem ubuntu, reexecute the commands wsl list, then it can work fine!

1
  • 1
    Welcome to SU. Your answer is a bit unclear. "... reports error at wsl list..." - which error exactly? OP doesn't mention errors with this command. Considering this and the fact that command ubuntu produces errors, maybe you could edit the answer to clarify how exactly this addresses the problem. I'd suggest taking the Tour and checking the Asking- and Answering -sections in the Help to find out how these sites work. Feb 20, 2023 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .