25

In a recent update, when I type a partial URL into the address bar, Chrome has started putting the suggested URL in parentheses after what I type, which means I'm not able to edit that URL before I press ENTER.

See example image below. Previously, when I typed the letters capt, and the first URL suggested is the one I'm trying to edit, I could press the down arrow once and it would put that URL into the address bar, and I was then free to edit that URL before pressing ENTER to visit it.

After a recent update, when I type the letters capt, the URL I'm trying to edit appears in the address bar in parentheses after what I type (you can see it in blue in the image), but I can't edit it. When I press the down arrow to try to select the URL from the list like I did before, the focus moves to the second thing in the dropdown. When I press the up arrow, it moves the selection back to the address bar with the URL still in brackets.

This is annoying because I have lots of similar URLs that I visit, and I was always able to type part of a URL, have Chrome fill in the full URL, and then I could edit the URL directly before pressing ENTER. Since the update, I can no longer do that - I have to visit the URL, and only then can I edit it.

Is there a way to stop Chrome putting the URL in parentheses in the address bar after what I type, and revert it back to its previous behaviour where it was editable? My Chrome version is Version 106.0.5249.181.

Thanks!

Example

9
  • Have you tried settings > "reset and clean up"? Nov 22, 2022 at 23:38
  • 1
    @JoepvanSteen I don't remember changing any settings recently, so I'm hesitant to do that - this will be a last resort.
    – Matt
    Nov 22, 2022 at 23:43
  • Press "RIGHT ARROW" !
    – Prem
    Nov 23, 2022 at 6:26
  • 3
    @Prem doesn't work unfortunately, the cursor just will not move within the brackets no matter if I push right arrow, click on it, or anything else I tried.
    – Matt
    Nov 23, 2022 at 20:26
  • 5
    Yeah, although this seems to be an intentional feature, this is definitely a UX bug, filed a Chromium bug here: bugs.chromium.org/p/chromium/issues/detail?id=1394443
    – Karl Horky
    Nov 29, 2022 at 16:31

2 Answers 2

19

Update [2022-12-01]


Workaround to edit the url:

  1. Type partial url until suggestion appears in parentheses
  2. Press Tab
  3. Press Tab again
  4. Press Shift + Tab

When focus returns to the url/search bar the suggested link changes from the parenthesised "suggestion" to an ordinary text url

For a shorter variation, this appears to work as well:

  1. Type partial url until suggestion appears in parentheses
  2. Press Shift + Tab
  3. Press Tab
4
  • 1
    That's fantastic. Not at all intuitive but it works, and I'm glad I'm not the only one with the problem!!
    – Matt
    Nov 27, 2022 at 18:53
  • 6
    Seems like this workaround may be a bug that the Chrome team will later "fix". Would be much better for Chrome to provide an option to disable this functionality (or even better - Chrome team could revert this "feature" 👍). Horrible UX.
    – Karl Horky
    Nov 29, 2022 at 16:11
  • 1
    Thanks! After playing with your workarounds, I found a variant I like better: Tab then Up (tested on v111.x). For some reason, I'm too clumsy for Shift+Tab 😅
    – NikT
    Apr 12, 2023 at 18:28
  • 1
    Tab,Tab,Shift+Tab doesn't work if the URL has an associated "search in [website]"; in such cases you'd need to press Tab a 3rd time before Shift+Tab. Hence the Shift+Tab,Tab combo is more consistent, I think. Jun 4, 2023 at 23:29
5

This was causing me problems for other reasons, but I disabled these chrome://flags and one of them seems to have removed the change:

Omnibox Rich Autocompletion Promising Combinations

Omnibox shortcut expanding

History Journeys Omnibox Action

3
  • 4
    Disabling Omnibox Rich Autocompletion Promising Combinations does make this behaviour go away, but it also loses the "auto-completion" in the URL too so you still have to use tab or the keyboard arrows to get to the suggestion you want to copy/paste the URL which is still a net negative (though better than the current default)
    – koopajah
    Dec 7, 2022 at 21:23
  • 1
    At first glance disabling the first one has fixed my problem, thanks! I'll work with that setting disabled for a while and see if it has any unwanted side effects for me!
    – Matt
    Dec 15, 2022 at 20:02
  • As of today, the first option is of course no longer there. Mar 20 at 12:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .