1

I have a bootable Windows 10 USB stick that does not boot from my desktop. In the BIOS settings, I can see the USB stick listed. I select it for boot override, and then the screen goes black for a few seconds then returns to the BIOS boot up screen.

I'm trying to install Windows 10 on one of the drives on this PC. A separate drive has Ubuntu installed; grub is also installed on this PC.

This PC previously had dual boot Windows 10 and Ubuntu. However, the Windows 10 drive failed so I removed it and installed a new drive. This is when I started to have these boot issues. I suspect that there may be an issue with the boot/grub settings.

I created the USB with instructions similar to this answer. I confirmed that the USB stick works with another computer (running Windows 10): I change the setting in BIOS to boot from USB and the Windows 10 installer loads up. I'm fairly confident that the USB stick is not the problem.

Things I have tried:

  1. Repaired boot using the Boot-Repair tool
  2. Tested both Legacy and UEFI options for Storage Boot Option Control in BIOS settings
  3. In the BIOS, there is a Windows 8/10 Features option that I also tested without success
  4. Confirmed that my PC boots from USB. It booted the Ubuntu 22 installer and also booted the Boot-Repair live disk from USB
  5. Tried different USB ports
  6. Enabled the Compatibility Support Module (CSM) setting in BIOS
  7. Turned on the USB's partition boot flag

Here is a paste from Boot-Repair's boot-info summary : https://pastebin.ubuntu.com/p/Q4MhpjJpMy/

What could be the issue?

References:

Cannot boot from bootable Windows USB

Can't boot from USB - even with BIOS set correctly

https://www.minitool.com/news/cant-boot-from-usb.html

https://www.easeus.com/computer-instruction/windows-wont-boot-from-usb-2018.html

Cannot boot Windows from USB, but can boot Ubuntu

Windows 10 ISO on USB stick won't boot

5
  • The drive Linux is installed on is it MBR or GPT?
    – Ramhound
    Nov 26, 2022 at 4:30
  • @Ramhound, the Linux drive's partition table is GPT
    – Zion
    Nov 26, 2022 at 4:40
  • 1
    If that is the case, then enabling CSM support, would result in Windows not booting. So you can skip any solution you find that suggests to do that. What tool did you use to make the installation media? Likewise, Leagcy, is only for MBR (with regards to Windows).
    – Ramhound
    Nov 26, 2022 at 7:48
  • When I disable CSM, only my Ubuntu drive is shown in the boot options; my Windows 10 USB is no longer shown. Tools: I used gparted to format the USB (GPT w/ NTFS), mounted the windows 10 ISO and copied the windows 10 ISO files to the USB. I verified that this USB works, as stated in question. I know instructions say to use FAT32, however, the install.wim file is over 5gb and cannot fit on a FAT32 fs.
    – Zion
    Nov 26, 2022 at 14:50
  • @Ramhound, your comments gave me a nice nudge towards the solution (posted below). Thank you!
    – Zion
    Nov 26, 2022 at 18:53

1 Answer 1

1

The USB stick was the problem.

While creating the USB, I started off with FAT32 and kept getting an error when copying over the 5GB+ install.wim file. Therefore, I formatted it as NTFS, copied the Windows 10 ISO files and tested it on a separate computer, which worked. However, as I have now learned, NTFS does not work for every computer.

Googling "install.wim too large ubuntu" gives this page as the top hit, which provides the solution to creating a working Windows 10 USB from Linux. In summary:

  1. Create partition table. Open gparted (sudo gparted) and select your USB drive. Click Device > Create Partition Table > select gpt > click Apply.
  2. Create FAT32 partition. In gparted, right click the unallocated space > click New. Set New size (MiB) to 1024, File system to fat32, label to UEFI_Boot, click Add.
  3. Create NTFS partition. In gparted, right click the remaining unallocated space > click New. New size can be left at the default remaining space. Set File system to NTFS and set label to WINDOWS10. Click Add, click the green checkmark ✅, then click Apply. Wait for the operation to complete then close gparted.
  4. Mount the Windows 10 ISO. In Ubuntu, open file explorer and double click the ISO file. This will mount it as a drive.
  5. In the UEFI_Boot partition, create a folder called sources. Copy/paste the boot.wim file from the ISO's sources folder into this new sources folder. This file is required for successful boot.
  6. Copy all other ISO files except the sources folder into the UEFI_Boot partition (i.e. autorun.inf, boot folder, bootmgr, bootmgr.efi, efi folder, setup.exe, and support folder).
  7. Copy the sources folder to the WINDOWS10 partition. Eject the USB once the files have copied over.

This process works and allowed me to boot up the Windows 10 installer.

References

https://techbit.ca/2019/02/creating-a-bootable-windows-10-uefi-usb-drive-using-linux/

https://win10.guru/usb-install-media-with-larger-than-4gb-wim-file/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.