2

I've found this annoying problem where if I press function keys they don't perform as expected. F12 opens up Chrome's inspector while F11 just hides windows to show desktop.

The only way I can click to say change brightness is to click the FN key.

What is causing this and how do I change it back to standard function key functionality? And what causes it in the first place?

6
  • Does this answer your question? How to use Function keys as standard key in one app only? Dec 2, 2022 at 9:09
  • @SaaruLindestøkke - it's not a great dupe match, though I'm surprised I can't find a better one at the moment. I'll drop in an answer & if we find a good one later we can always close it against that.
    – Tetsujin
    Dec 2, 2022 at 9:20
  • Yes, I see that it's not a very good match. I referenced that question as it also refers to a question over at Apple.SE, but the answer on this question is maybe a better fit? Dec 2, 2022 at 9:25
  • @SaaruLindestøkke - all useful, but tbh, I think it might be OK to leave this one as a standalone 'how do i switch it over, just the once?'. Simple Q, simple A. the others have now populated the sidebar, for deeper interest. I guess we'll have to see what others think. [I'm easy either way, really:)
    – Tetsujin
    Dec 2, 2022 at 9:34
  • I'm using Monterey and it just keeps switching. Can't find the option to switch back to normal functionality System Settings for me has caused all sorts of trouble.
    – elksie5000
    Dec 2, 2022 at 9:38

1 Answer 1

3

You can set which way this behaves in System Prefs > Keyboard > Keyboard
'Use F1, F2, etc. keys as standard function keys'

enter image description here

Whichever way you choose, holding Fn/F-key will activate the opposite mode temporarily.

This pref pane has changed appearance slightly over the years, but the functionality remains the same up to Monterey, but it has moved in Ventura.

enter image description here

from Apple KB

macOS Ventura
Choose Apple menu  > System Settings.
Click Keyboard in the sidebar.
Click the Keyboard Shortcuts button on the right.
Click Function Keys in the sidebar.
Turn on "Use F1, F2, etc. keys as standard function keys".

4
  • I'm using Monterey and that doesn't appear under System Settings > keyboard.
    – elksie5000
    Dec 2, 2022 at 9:36
  • It's in just the same place on Monterey - i.stack.imgur.com/KArk1.png Ventura may have changed things, but I don't have that yet on any of the Macs here.
    – Tetsujin
    Dec 2, 2022 at 9:39
  • Answer updated with Ventura changes
    – Tetsujin
    Dec 2, 2022 at 10:47
  • Once I worked it, it worked. Well done done Sir.
    – elksie5000
    Dec 2, 2022 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.