I got a new computer a couple of months ago, and since the very beginning I've been having some problems with the memory. At the beginning the problems seemed more random, but after updating to a newer BIOS the problem has been this:

When I boot up my computer for the first time after it has been shut down for some time, it always crashes when loading Windows, or if it manages to get to Windows I get applications crashing followed by BSOD. Running Memtest during start up shows up a huge number of errors.

However, when I shut down the computer (not just restart, but really shut it down), and then start it again, everything works fine. Memtest shows no errors, and I can keep the computer up for days and run any stress test and there's nothing wrong.

Then the next morning the same thing always repeats. First boot-up -> mem errors, bsod, crashes -> Second boot-up -> everything works fine.

I'm pretty much at loss here, since I've never really seen anything like this before. Here's what I've tried so far:

  1. Loads of different BIOS settings, also with the help of support person from the memory manufacturer Mushkin. Different settings don't seem to make much difference, with the second boot pretty much every reasonable setting seems to work, and with the first boot nothing does.
  2. Run two passes of Memtest on a different computer for both memory sticks, both came up with no errors.
  3. Booting up with just a single stick of RAM. This usually works better, the first boot shows less errors and comp is usually stable. Nevertheless, there still are memory errors.
  4. Reassembling the whole computer (CPU, memories, display adapter etc.)
  5. Updating BIOS, currently running the newest version (1101)

I haven't been able to try memory from other manufacturers since none of my friends have DDR3.

Here's the specs of the computer in question:

Asus P7P55D-E
Intel Core i5 750 2.66 Ghz
2x2048MB Mushkin Blackline DDR3-1600 CL7 Kit "Stiletto" (7-10-10-24)
1024MB Asus Radeon EAH5850 DirectCu
80GB Intel X25-M
Antec P183
Enermax 525W Modu 82+ II
Windows 7 64-bit

My friend ordered a completely similar configuration at the same time and he's having same kind of problems, so I find it hard to believe there's problems with the hardware (unless there's been a whole box of faulty memories of course).

So is there any ideas of what could I still try, or what is the most likely reason for this problem?

Thanks in advance!

  • 3
    I get memory errors when I first wake up, too, have you tried coffee? – Phoshi Aug 14 '10 at 10:36
  • Have you contacted Asus support about the issue? be sure to tell them it is happening on 2 different systems with the same mobo. Maybe try a different brand of memory to rule out memory compatibility issues. – Moab Nov 12 '10 at 2:58
  • 1
    I have not contacted Asus about the issue, maybe I should though. I actually still haven't had a chance to test the mobo with different memory brand, but hopefully it will happen soon. – sdb Dec 11 '10 at 10:23

It sounds like a temperature-related problem. Unfortunately, with tolerances in consumer-grade component manufacturing being so wide, these kinds of problems will show up on occasion. It could be a batch of flaky memory sockets or a flaw in the motherboard. It could also be a fault in the way the motherboard is installed in the case. Any unusual pressure placed on a component (e.g. the motherboard) due to incorrect mounting would tend to affect behaviour differently as the operating temperature changes. You've already tried most of what I would suggest, other than removing the motherboard from the case and carefully reinstalling it, making sure it is not attached in any way crooked or such that it is being flexed. Standoffs are your friends. I recently purchased a shop-assembled motherboard-case-power supply from a reputable store and they messed up the motherboard install in several ways, causing it to flex much more than recommended. Luckily I noticed it and fixed it myself.

  • Thanks for your answer. I think my next step will be to see if the problem occurs when the motherboard is outside the case, so at least I can eliminate the chance of a faulty installation. I'll post the results here. If it doesn't work, I'll guess I'll have to assume that the motherboard is flawed, and see if the warranty would cover it. – sdb Aug 14 '10 at 16:53
  • Hi, finally found the time and motivation to remove the motherboard from the case, and tried to run the computer with motherboard outside the case. Unfortunately the memory errors still seem to occur, so I guess it's not a faulty motherboard installation either. Asus also released a new BIOS couple of days ago, but that did not help either. I guess I'll wait until I can test the configuration with RAM from some other manufacturer. – sdb Sep 8 '10 at 20:25

It could be a memory compatibility issue, only way to know is to use memory listed by Asus to be compatible.

There are 7 versions of that board, which is yours? http://support.asus.com/Download/ModelList.aspx?SLanguage=en&keyword=P7P55D-E&type=1

Once you pick your specific board and OS, you will see a "qualified vendor list" download zip file that contains PDF's, this will list memory guaranteed to be compatible with that board.

If you still have errors using listed compatible memory, I would contact ASUS support about the issue, it could be a bios bug or defective motherboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.