I did a careless mass delete on my downloads folder a couple days ago, and I'm trying to recover a single Excel file that was among the deleted files. With a file recovery program, I found 2 versions of it that, according to the recovery program, are in "Excellent" state, with "No overwritten clusters detected". But when I recover either one of those files and try to open them in Excel, I get the following error message:

"Excel cannot open the file "filename.xlsx" because the file format or file extension is not valid. Verify that the file has not been curropted and that the file extension matches the format of the file."

I've tried a couple different techniques, including:

  1. Renaming to .zip, then unzipping with 7zip (results in a "file is not an archive" error)
  2. Using an Excel recovery tool (none of the 2 I've tried have been able to recover the file)
  3. Using Excel's built in recovery tool (tells me that it can't recover the file).

All I need to be able to do is view 2 columns of data, even if it's in plain text or coded, but I can't seem to get it to open in anything. Any ideas?

  • Wrong site. You're looking for Super User instead. SO is for programming-related questions only. You can find more information about this site in the help center.
    – Ken White
    Commented Dec 17, 2022 at 3:01
  • What about downloading it again? You must know where you got it from.
    – Solar Mike
    Commented Dec 17, 2022 at 8:31
  • Was it deleted from an SSD? View contents in HxD (google it). Maybe add screenshots for both files to post. Commented Dec 19, 2022 at 13:36

1 Answer 1


With a file recovery program, I found 2 versions of it that, according to the recovery program, are in "Excellent" state, with "No overwritten clusters detected".

This does not mean a whole lot if files were deleted (and then later recovered) from a SSD, so this may be what's going on.

File recovery tools, undelete type tools can compare clusters that were allocated (but now 'released') to the file system 'Bitmap' in which used clusters are tracked. If clusters that were allocated to the deleted file are marked 'not in use' in the Bitmap, the undelete tool in general will rate recoverability as excellent or similar. Simply on the assumption the released clusters haven't been overwritten yet.

On an SSD however an additional TRIM command is sent to the SSD. In most cases the SSD will 'unmap' associated sectors (that were part of the deleted file) and simply return zeros if these sectors are read. IOW, the file recovery / undelete tool is recovering zero filled files.

It's also important to note that in many file system the 'file entry' itself is not deleted, and this how the undelete / file recovery tool can still detect the deleted file.


File deletion > File is flagged 'deleted' at file system level > clusters allocated to file are 'released' > OS converts cluster addresses to LBA sector addresses > OS sends TRIM command to hard drive with range of LBA addresses > SSD 'unmaps' the LBA addresses. Until written to these LBA addresses, the SSD delivers zero filled sectors if these LBA addresses are read from.

I made this video to demonstrates this: https://youtu.be/NyLQbxnPurc

You must log in to answer this question.