0

I'm asking this question because I'm really out of my element when it comes to networking, so I apologize in advance if there's an obvious solution to my problem.

I'm hosting a server that serves the website for an iOS app I maintain, as well as providing some very basic backend API functionality. The issue, very broadly, is that the server hostname fails to resolve for some users some of the time, seemingly randomly.

The error I get back from my app is A server with the specified hostname could not be found. I've encountered the issue on my own devices as well, opening the website in a browser will then fail with a similar error. For myself, the issue has always gone away after waiting some time - most of my users never try again after they encounter the error, so I don't have any good data there.

Setup

Domain: https://mathical.io (hosted on AWS Route 53)

Server: Apache/2.4.38 (Debian)

SSL certificate: Let's encrypt

Host: Linode Nanode 1 GB

OS: Debian 10

Framework: Symfony

What I've tried

My first instinct was that the DNS config may be wrong, so I checked the A and AAAA records on dnschecker.org. A seems to resolve fine everywhere, while AAAA fails to resolve from some of the servers, but I don't really know if that is unusual or worrisome.

I also checked the error and access logs on the server but didn't find anything interesting, but the error message suggests to me that the request never even reaches my server, so that might explain it.

If anyone has any idea what I could try next to narrow down the issue, or if there's more information I could provide, I would greatly appreciate the help!

2 Answers 2

0

Not sure if you are pointing the Route53 DNS entry to a load balancer (if you have it) or to some EIP (Elastic IP Addresses), though I would prefer a DNS entry pointing to a LB.

Never point a DNS entry to the IP addresses that you get when you resolve your LB name.

Try to set your TTL on Route53 to the smallest value (which will create more traffic to Route53, but that's fine).

0

Thanks for answering. I think I have solved the issue by setting the correct DNS records on Linode as well as AWS. I'm not sure why that was necessary, but since doing so, the dnschecker passes fine and the issue has not reoccurred.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .