I'm trying to set up public port forwarding so that external requests get forwarded to my Home Assistant server.

My setup is:

4G Modem with SIM Card (Huawei B535-333)
Linksys Velop WiFi Mesh Router
Raspberry PI running Home Assistant

The 4G Modem is set in Bridge Mode, and all router functions seem disabled.

Port forwarding is set on Linksys router:

External port Internal Port Protocol Device IP
443 8123 TCP

Accessing the Home Assistant server works fine if I use a local address on the 8123 port.

I tried to use https://www.yougetsignal.com/tools/open-ports/ to test what open ports I have, yet nothing seems to be open on my IP (tried 443, 8123, 80, etc)

I've also checked for logs on my Linksys router but there are no "Incoming connections" logged or "Security" events. I'm suspecting that the 4G Modem is dropping all incoming connections, but I can't see that anywhere. Is "Bridge Mode" a valid way to setup the connections between these 2 network devices?

This is what the 4G modem admin interface says regarding bridge mode:

Bridge Mode

In bridge mode, only one device can connect to the Internet at a time. Note:

  1. In bridge mode, you can only access the Internet using mobile data.
  2. If you enable bridge mode when not connected to the Internet, or manually disconnect from the Internet in bridge mode, you will be logged out of the page. You will need to manually assign a static IP to your computer to log in again.

I'm not sure what I'm doing wrong or how I can further debug the issue.

Here's a diagram of the setup if it helps:

network setup diagram

  • 2
    Before anything else, have you checked whether the modem has a public IP address at all? Its status page has a "WAN IP Address" under "Device Information". Does it show a public address or a private one? Does the address shown in the status page match the address shown by Google? Commented Dec 27, 2022 at 20:45
  • Did you add an allow firewall rule for your port forward?
    – Dr_Xunil
    Commented Dec 27, 2022 at 20:48
  • 1
    Be aware that most cellular services either use Enterprise grade NAT or block all incoming connections (regardless of what port it is on)... This is often not a usable scenario you are trying to do.
    – acejavelin
    Commented Dec 27, 2022 at 20:50
  • @acejavelin wow! I didn't know that... You mean that anyone using SIM internet, that wants to do home networking and setup public servers at home have no possibility of doing so?
    – Cristian
    Commented Dec 27, 2022 at 20:56
  • 1
    Do you have internet in your network with this setup? Have you contacted your ISP Support and asked if you need a static IP for incoming connections? (Note that a static IP may require additional payment.)
    – harrymc
    Commented Dec 27, 2022 at 21:22

1 Answer 1


You're probably now behind a Carrier-grade NAT, so without a static IP you can't have incoming connections. This option often requires additional payment to the ISP.

As an alternative to the static IP, you could also use a VPN that supports port-forwarding. A random example is PureVPN as described in How to setup Port Forwarding & bypass CGNAT.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .