Is this a joke?
Nothing as simple as running a program as administrator: click-right on the name of the program in Windows explorer, choose "Run as administrator" from the context menu and off you go!

No, it's not that simple:
I have followed the advise from this other StackOverflow post and I've downloaded cPorts program. The program is meant to close obsolete TCP sockets but admin rights are needed for doing that (when trying to close a TCP socket, this message appears: "Failed to close one or more TCP connections. Be aware that you must run this tool as admin in order to close TCP connections.").
So, I run this program as administrator (right-click in Windows explorer, ...) and try again, but again I fail with the same error message.

When viewing the task manager, this is what I see ("DDM" is my username):

enter image description here

So, I'm facing two possible problems here:

  1. I tell my computer (Windows-10 Professional) to launch a program as admnistrator and he didn't. Why not?
  2. I tell my computer to launch a program as administrator, he did but it's not visible in task manager. (But then where can I verify this?)
  3. I'm being confused between the terms "admin" and "admnistrator".

Does anybody know which is my case and how to handle it?

For your information: I tried tasklist /V | findstr /I "adm" but this also did not show the cPorts.exe, which I'd launched as administrator.
I also have Process Explorer, but I don't know which colun has the information "being run as admin(istrator)".


2 Answers 2


Run as Administrator actually don't change the user, but elevate the process to admin status. It's possible to see this in Task Manager, there is a column called 'Elevated'.


The error message does not say that the operation failed because of missing privileges. The error message simply says that the operation failed but it doesn't say why or how the operation failed, it does not give any reason nor any explanation. In addition, the error message reminds you that you need to run the program with elevated privileges, but there is no reason to believe that this has anything to do with the problem.

The most likely explanation is that the operation failed for "some reason" and the author of the tool has not put in proper error handling and simply treats every failure with the same message.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.