I want to use a very old app (I think it was created for Windows XP) on Windows 11. The app supposes to work in Hebrew. Unfortunately, it shows some gibberish characters instead of Hebrew.

Here is a screenshot

I want to say that I have the very same app working perfectly on my other system with Windows 10, and I also tried all the methods written at the Super User Question Windows 10 displays gibberish text in some apps with no success.

  • 1
    do you have the Hebrew font(s) installed?
    – Keltari
    Jan 26 at 20:53

3 Answers 3


If it is related to fonts and to test it

  1. Go to in the other system ( windows 10 )
  2. Navigate to C:\Windows\Fonts
  3. Look for any Hebrew fonts and copy all of them or copy all the fonts to a shared folder or a Pendrive
  4. Past the fonts in the same location (C:\Windows\Fonts) in the windows 11
  5. Do a Font Cache Cleaning by any software or Better Manually
  6. Restart the computer if needed
  • 1
    It actually worked! Much appreciated :)
    – Omer
    Jan 31 at 14:16

Seems like the application is asking for a font that doesn't exist on your computer. Windows is trying to find a replacement font and doesn't do it very well.

I suppose that you have installed the Hebrew language on the computer.

To trace which fonts the app is trying to use, you could perhaps try SysInternals Process Monitor to find out what font files the process is looking for while it is running.

Use the Filter button to add a filter for "Process Name is oldapp.exe", and add filters for "Path includes" for typical font file-name extensions such as .fon, .otf, and .ttf.

You might be lucky and find it this way.

  • I didn't manage to find the specific font, but I copied all of my fonts to the new system and now it's working. Thanks!
    – Omer
    Jan 31 at 14:17

I want to use a very old app (I think it was created for Windows XP) on Windows 11.

There are limits on what old software you can run on Windows 11.

(1) Try a VM. For software as old as Windows XP, you will need to set up a Virtual Machine and run the software in an old OS Virtual Machine.

XP Still runs as a VM - I have that here.

Windows 7 still runs as a VM - I have that here as well. The software may run in Windows 7.

You might also try a Windows 10 VM.

So that is your way forward for the software you want.

XP, Windows 7 will not run as real machines on new hardware. Windows 10 should run on modern hardware.

(2) Try Compatibility Mode: Also if the software will perform properly in Windows 10, then another approach is to try Compatibility Mode while installing. Make sure the App has been fully uninstalled, restart, install and in the install dialogue, select Compatibly Mode. That may work. Try and see.

The 2 ways outlined are the only ways I know when an App will not install natively in Windows 11

  • Thank you for your answer. As I said, it actually runs fine on another system with windows 10. Besides that, the app works fine here too but I just can't read the text. So maybe there is a solution that doesn't involve VM. Again, thanks!
    – Omer
    Jan 26 at 19:40
  • Try installing in Compatibility Mode.. I outlined that in my answer.
    – John
    Jan 26 at 19:45
  • It's actually a portable app (without installation). I tried to run it in Compatibility Mode with no success...
    – Omer
    Jan 26 at 20:16
  • So then you need a VM App that will to USB passthrough and run it that way. That is about the only other approach you can use.
    – John
    Jan 26 at 20:21
  • 1
    Compatibility mode or a VM will not help produce a font that doesn't exist. Jan 26 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.