1

I am getting this error whenever I am launching AVD:

The emulator process for AVD has terminated.

I have already checked possible solutions on YouTube, Stack Overflow, Superuser and whatnot but none of them seem to work for me.

I have already checked below and it did not work

  • Available space in drives
  • HAXM installer is also installed
  • Already tried deleting the AVDs
  • Checked the api version
  • what else.. yes Emulator launch in a tool window - check uncheck done.

Prior to this error, I was getting error timed out after 300seconds waiting for emulator to come online. I guess I made some change and got this new error. Not sure if I have gone even backwards.

My OS - Windows 8, Android Studio version: Android Studio Electric Eel | 2022.1.1 Patch 1

Here you can see the logs from idea.txt

2023-02-08 17:58:05,095 [3915750]   INFO - Emulator: Pixel 6 API 28 - C:\Users\Admin\AppData\Local\Android\sdk\emulator\emulator.exe -netdelay none -netspeed full -avd Pixel_6_API_28
2023-02-08 17:58:05,142 [3915797]   INFO - Emulator: Pixel 6 API 28 - Android emulator version 31.3.15.0 (build_id 9456632) (CL:N/A)
2023-02-08 17:58:05,157 [3915812]   INFO - Emulator: Pixel 6 API 28 - emulator: INFO: Found systemPath C:\Users\Admin\AppData\Local\Android\sdk\system-images\android-28\google_apis\x86\
2023-02-08 17:58:05,157 [3915812]   INFO - Emulator: Pixel 6 API 28 - emulator: INFO: Found systemPath C:\Users\Admin\AppData\Local\Android\sdk\system-images\android-28\google_apis\x86\
2023-02-08 17:58:05,157 [3915812]   INFO - Emulator: Pixel 6 API 28 - Could not launch 'C:\Users\Admin\AppData\Local\Android\sdk\emulator\qemu\windows-x86_64\qemu-system-x86_64.exe': Invalid argument
2023-02-08 17:58:05,188 [3915843]   INFO - Emulator: Pixel 6 API 28 - Process finished with exit code 22
2023-02-08 17:58:06,146 [3916801]   INFO - #c.a.t.i.a.AvdManagerConnection - C:\Users\Admin\.android\avd\Pixel_6_API_28.avd\hardware-qemu.ini.lock\pid not found for Pixel_6_API_28
2023-02-08 17:58:06,146 [3916801]   INFO - #c.a.t.i.a.AvdManagerConnection - C:\Users\Admin\.android\avd\Pixel_6_API_28.avd\userdata-qemu.img.lock\pid not found for Pixel_6_API_28
2023-02-08 17:58:06,147 [3916802]   WARN - #c.a.t.i.a.AvdManagerConnection - Unable to determine if Pixel_6_API_28 is online, assuming it's not
2023-02-08 17:58:08,375 [3919030]   INFO - #c.i.c.ComponentStoreImpl - Saving appDebuggerSettings took 93 ms, DontShowAgainFeedbackService took 16 ms, FileTypeManager took 16 ms, FindSettings took 15 ms, LafManager took 16 ms, PropertyService took 31 ms, XDebuggerSettings took 15 ms
2023-02-08 17:58:08,563 [3919218]   INFO - #c.i.c.ComponentStoreImpl - Saving Project(name=First Application, containerState=COMPONENT_CREATED, componentStore=E:\Software\Android\FirstApplication)CompilerConfiguration took 16 ms, GradleSettings took 16 ms, RunManager took 15 ms, StructureViewFactory took 16 ms
1
  • Welcome to the community. In Review I rejected an edit to this question, as it's inappropriate. SE sites aren't discussion forums, issues aren't marked "SOLVED", but helpful answers are accepted. The right way to mark this solved is to write the solution into an answer even if you solved it yourself, then accept the answer. I'd suggest taking the quick Tour and checking the Asking and Answering in Help to get a handle on how the site works :-) Commented Feb 8, 2023 at 18:14

1 Answer 1

0

I had this same issue but the solution is that MPFlat.dll is a core part of the android studio emulator all you have to do is download MPFlat.dll and add it to your emulator directory C:\Users\user\AppData\Local\Android\Sdk\emulator\ Download MPFlat.dll from this link

Also run this command in your emulator directory: emulator -netdelay none -netspeed full -avd Pixel_4_API_33 -qt-hide-window -grpc-use-token -idle-grpc-timeout 300

But change the Pixel_4_API_33 to the emulator you created on android studio

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .