4

For my class I am running a Windows 2019 datacenter server with AD DS and Hyper-V. The goal is to create a windows 10 consumer virtual machine in hyper-v and start it, however it currently will not start. It gives the error listed in the title.

I have “enabled nested VT-x/AMD-V” checked. In acceleration, I have hyper-v for the paravirtualization interface. The vNIC is set up properly and the ISO for the Windows 10 is fine.

On my laptop that is running this, I have tried having these settings both on and off before trying to start the hyper-v vm: Hyper-V Hyper-V management tools Hyper-V platform Windows Hypervisor platform

I have tried the bcdedit command, both on auto and off. I also tried stopping and starting vmms. I tried Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V -All, as well as disabled. I tried DISM.

Something to note: When I tried Set-VMProcessor -VMName “WS2K16” -ExposeVirtualizationExtensions $true it said it could not find a VM by that name. When trying systeminfo, I will get a message like this “A hypervisor has been detected. Features required for Hyper-V will not be displayed”.

I checked BIOS and the virtualization feature is enabled.

I have tried having these both on (running) or off in services:

Hyper-V host computer services Hyper-V virtual machine management

I’m at a loss on what I should do and have hit a wall at this current point.

What I expected to happen at some point was for the VM to start so I could then begin the windows 10 downloading process.

3
  • Unclear : You have both Hyper-V and VirtualBox?
    – harrymc
    Feb 11, 2023 at 10:59
  • Pretty sure that VirtualBox doesn't pass through SLAT to VMs, which is a requirement for Hyper-V (after the Windows Server 2008 version) so you won't be able to nest a Hyper-V VM inside of a VBox VM....unless something changed in the 7.x version, 6.xx didn't allow this
    – essjae
    Feb 11, 2023 at 11:59
  • @harrymc yes, I have virtualbox and within it I have a domaincontroller I made using windows server 2019 with active directory domain service. It also has a secure DNS server and hyper-v. I am then supposed to create a virtual machine within hyper-v.
    – Lux-Spawne
    Feb 11, 2023 at 18:29

1 Answer 1

2

You're trying to use Nested virtualization, running a hypervisor (Hyper-V) inside a VM running on Virtualbox.

Nested virtualization does not work between different virtualization products, and there are not many that support it to start with.

Under Windows, you need to use a Generation 2 VM to support Nested virtualization. You can't use Virtualbox for that. You need a Windows host that is at least the latest version of Windows 10.

I suggest to re-recreate the VM under Hyper-V. You might be able to build the Hyper-V VM around the virtual disk that was created by Virtualbox, since most virtualization products today support multiple disk formats.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .