I have a SSD Harddisk with both an usb and Sata connection, and I want to be able to boot both from usb and sata but I can't make it work.

When the disk is connected with sata anything works fine but when I connect it with usb instead, Fedora seems to boot but then it gives me an "No root device found" error and just sleep forever.

This happens even if I install fedora 13 while the disk is connected with usb.

I am running Fedora Core 13.

Updates: I changed my fstab to

/dev/sda2 / ext4 defaults 1 1

and the disk is still booting when connected to the sata controller. So far so good. But if i boot from the usb connection, it still give me the same "No root device found" message.

Even more odd is it that if I boot my fedora core 13 dvd, and choose "rescue installed system" it can't detect the harddisk when connected to usb. And there is no /dev/sd* or anything similary which could look like a blockdevice. Did redhat forget to include usb drivers in their rescue image for Fedora core?

I just tried the disk on an other system, with exactly the same problems.

Update 2: I have now added the LABEL=myroot line to fstab(I guess it have to be uppercase to work) and the harddisk still boot fine when using sata, but it still can't boot using usb. I begin to guess that redhat forgot some usb drivers In fedora Core 13, because the system can't see the harddisk when booting the dvd and entering rescue mode. blkid don't show any harddisks at all and there are no block devices in /dev/ which might be my usb disk.

btw: Is it possible to find the uuid of partitions if id add the usb harddisk to a windows computer, and more important: will this be the same uuid as linux will se.

migrated from serverfault.com Aug 17 '10 at 13:40

This question came from our site for system and network administrators.

  • 2
    The problem is the root file system identification in /etc/fstab isn't the same on USB as it is on SATA. The solution may involve moving back to using a Label instead of a UUID. – kmarsh Aug 17 '10 at 12:52
  • @kmarsh: You should add that in as an answer – GregD Aug 17 '10 at 12:57
  • Should I use label=/dev/sda or label=/dev/sda2 If mount gives me: /dev/sda2 on / type ext4 (rw) – MTilsted Aug 17 '10 at 13:09

The problem is the root file system identification in /etc/fstab isn't the same on USB as it is on SATA. The solution may involve moving back to using a Label instead of a UUID.

/dev/sda2 would be the old-style partition name. This may work well, as long as it is a pseudo-SCSI device on both SATA and USB. I'm not sure the "/" character is legal within a Label.

To use labels, you have to label the partition and then set the label name.

For example:

e2label /dev/sda2 myroot

and then use


Update 2:

Please tell us what hardware you are booting.

To get USB support on bootup, you may have to add the USB kernel module to the ramdisk used on bootup using mkinitrd. (Or maybe update-initramfs -u).

According to this thread's first answer, it is pretty easy on Fedora. I can't find specific instructions immediately.

  • How exactly should that label=myroot line be? The line I tried in my fstab was label=myroot / ext4 defaults 1 1 But then i just get something with label=myroot being unknown. – MTilsted Aug 19 '10 at 9:28
  • It should be just that. Maybe LABEL in all caps. Question, have you successfully labeled your hard disk partition yet? If not, it is sure not to find it. – kmarsh Aug 19 '10 at 14:58
  • I guess it had to be uppercase. Label is working now for sata but not for usb. (Se update 2 in description). – MTilsted Aug 19 '10 at 18:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.