I am using the Homegroup feature in Windows 7. Usually, the folders I have specified to be shared are available across all of the computers on the Homegroup, as desired.

Unfortunately, when new files are added to these folders, there is a significant and seemingly random delay before they are pushed to the other computers. I assume that the way Homegroup works is that it runs some service in the background and that after a set period of time, this rescans shared folders and shares any new files found.

Is there any way I can manually push files to the Homegroup so that they are available as soon as I add them to one of my shared libraries?

  • Homegroup may not be up to this kind of functionality. Would SSH, FTP, etc. etc. work? – digitxp Sep 5 '10 at 13:38
  • These won't work. I'm trying to share videos with my Xbox 360 via HomeGroup. It works great but does not automatically share new content. There must be some sort of trigger that sets it off. If I know that trigger, I can set it off manually. – Rupert Madden-Abbott Sep 5 '10 at 13:55

Homegroups are just a mechanism to enable the file sharing feature built into Windows, so the most likely place this problem occurs is the Xbox's polling of the shared folder. Perhaps a re-scan initiated from your Xbox, or a reboot of the Xbox would index the share?

  • I've tried rebooting both the Xbox and the computer but neither triggers pushing the files. How would I go about initiating a re-scan from my Xbox? – Rupert Madden-Abbott Sep 10 '10 at 19:29
  • It might not be a feature of the Xbox firmware to "re-scan", but removing and re-adding the share directory or the media center extender relationship would certainly trigger a re-scan. – Garrett Sep 11 '10 at 1:38
  • That works! It is a pain but it works! – Rupert Madden-Abbott Sep 11 '10 at 12:38

The thread Xbox 360 not seeing all files in shared videos concludes by :

I figured out the problem, i was copying and making new folders to d:\shares\videos, now i started copying them to \\server\videos and they show up.. Not sure why that mattered but it works now.

It's a weird solution, but it does have a kind of a twisted logic: If you copy the new content to the shared-folder using the network-share name rather than the local name of the directory, maybe the Homegroup refresh mechanism does get triggered.


I had this problem, I went to Control Panel → Network and Internet → Network and Sharing Center → Media streaming options.

On the "Xbox 360 device" next to the "allowed" drop down box was "customize". In "customize" I unticked "use default settings" and then ticked "Make all of the media in my library available to this device", clicked "OK" and "OK" and done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.