I have Win10 x64 Pro. The system doesn't have any COM or LPT ports, yet when I look at printer properties I have all the normal LPT1->LPT3, and COM1->COM4. I assigned the ABS PDF Driver v400 to LPT1: presuming that attempting to write to LPT1 would redirect to that printer. Unfortunately it doesn't work.

When I try to access it from the command line I get the following:

 >copy con lpt1
 The system cannot find the file specified.
 0 file(s) copied.

 >copy con lpt1:
 "lpt1:" is not a recognized device.
 The system cannot find the file specified.

 >type somefile.txt > lpt1:
 The system cannot find the file specified.

 >type somefile.txt > lpt1
 The system cannot find the file specified.

I have some older software that uses lpt1: lpt2: and com1: devices for output. How can I get Windows to make the LPT and COM devices available?

Also, why do they make it available via Ports in printer properties when they don't exist. It only makes sense they did that to emulate those ports, but it's not working?

So I tried the network share method. I was in settings (manage your device) of ABS PDF Driver v400 when I did this:

 >net use LPT1: "\\mysystemname\ABS PDF Driver v400"
 The command completed successfully.

 >copy con lpt1
 test it.
        1 file(s) copied.

At this point the Manage your device in Win10 has gone haywire, where the printer status is cycling between 1 and 2 document(s) in queue. If you open the queue, it's going bonkers constantly refreshing with 1 and 2 documents going back and forth. Like it's stuck in a loop. I right clicked and canceled all documents, now it's empty.

I deleted that LPT1:, removed the share on ABS PDF Driver v400 and setup a share to my actual printer HP Laser Jet M400. When I ran my testit test, it actually printed.

So there is multiple questions here, but one main question is:

Why do they allow the ports to be chosen in printer ports if they aren't going to emulate them the way "Net Use" does automatically? There has to be a reason for it.

  • 1
    Even if your system doesn't have traditional serial and parallel ports, some others do. If you had one, would you prefer needing to add it manually instead of the operating system providing it as it used to? Feb 19 at 22:36
  • 2
    Get a USB to Parallel Converter. Been there, done that, successfully.
    – John
    Feb 19 at 22:41
  • IIRC those create additional LPT ports to the existing ones. If some legacy SW is hardcoded to use LPT1 could this be made workable? Feb 19 at 22:44
  • The one I had used LPT1. Windows 7 machine. I do not see Parallel printer any more and Seven is gone
    – John
    Feb 19 at 22:46
  • 2
    The other thing you can do (done it, works well) is get a Parallel Print Server and put your printer on your network. Works great. Parallel Printer servers are still readily available.
    – John
    Feb 19 at 22:59


You must log in to answer this question.

Browse other questions tagged .